Contents

Part I Overview ............................................................................................................. 1
  1.1 Product Overview .............................................................................................. 1
  1.2 Technical Index ................................................................................................. 2
  1.3 Operating Principle .......................................................................................... 3
  1.4 Instrument ports ............................................................................................... 3

Part II Driver and Software Installation ................................................................. 5
  2.1 USB Driver Installation ...................................................................................... 5
  2.2 Sound Card Setup ............................................................................................. 6
    2.2.1 Sound Card Driver Installation ................................................................ 6
    2.2.2 Sound Card Configuration ....................................................................... 7
  2.3 Driver Installation Inspection .......................................................................... 7
  2.4 CRY6151 Software Installation ...................................................................... 8

Part III Software Introduction .................................................................................. 9
  3.1 User Management ............................................................................................. 9
    3.1.1 User Login .................................................................................................. 9
    3.1.2 User Management ..................................................................................... 9
  3.2 Menu Bar Introduction ..................................................................................... 9
    3.2.1 File (F) ..................................................................................................... 10
    3.2.2 Operation (O) .......................................................................................... 10
    3.2.3 Calibration (A) ......................................................................................... 10
    3.2.4 Setup (S) .................................................................................................. 10
    3.2.5 View (V) .................................................................................................. 10
    3.2.6 Curves (C) ............................................................................................... 11
    3.2.7 Data (D) .................................................................................................. 11
    3.2.8 Tools (T) .................................................................................................. 11
  3.3 Sequence and Measurement Step .................................................................... 12
  3.4 Instrument Calibration ...................................................................................... 13
    3.4.1 Instrument Internal Calibration .................................................................. 14
    3.4.2 Measurement Microphone Calibration ..................................................... 14
3.4.3 Artificial Mouth Calibration

3.5 Interface Display

3.5.1 New Graph

3.5.2 Arrang Curve Window

3.5.3 New Data

3.5.4 Status Bar

3.5.5 Sequence Verdict

3.5.6 Differential Value

3.6 Instrument Self Test

3.7 Multimeter

3.8 Signal Generator

Part IV Software Setup

4.1 Sequence and Measurement Step

4.2 Measurement

4.2.1 Input & Output

4.2.2 Frequency Response

4.2.3 Average Frequency Response

4.2.4 Frequency Response Grade

4.2.5 Balance

4.2.6 THD

4.2.7 Impedance

4.2.8 F0 and Q Value

4.2.9 Mic Current

4.2.10 Phase

4.2.11 Loudness Verdict

4.2.12 Output Code

4.2.13 Other Setup

4.3 Message

4.4 Extrigger

4.5 Serial Number

4.6 Serial Port

4.7 IO Code
Part I Overview

1.1 Product Overview

CRY6151 is the newest electro-acoustic analysis system developed by CRY Sound with powerful functions and strong stability. It can measure the performance of headphones (USB, Bluetooth, ANC), microphone (electret, dynamic and MEMS), receiver, micro speaker, speaker, communication helmet, etc. The measurement parameters include frequency response, sensitivity, impedance, distortion, resonant frequency (F0), balance, position of headphones, phase polarity, current and voltage of microphone, signal to noise ratio (SNR), directivity, T&S parameters, loudness rating and so on. The frequency range is 20Hz-20kHz.

Technically, CRY6151 electro-acoustic analysis system is not only a new breakthrough in the series products of CRY6125, CRY6135, CRY6136, but it also the earliest instrument that can test the Bluetooth Audio, as well as realize auto pair without manually click.

The software and hardware of CRY6151 has been fully upgraded.

**Hardware:**
Use the current most popular USB2.0 interface to transfer the data, to obtain a faster speed and more stable and reliable data; adopt the four-channel synchronous acquisition method to collect the data, which can realize two headphones and two microphone assemblies test.

**Software:**
V8.0 is based on Windows 7 & 32 bit system and supports Win XP and Windows 7 & 64 bit system (needs to update the driver). It has friendly interface, convenient operation and powerful functions. Besides having all test functions of early electroacoustic instrument, the following functions have been added:

- Higher and faster test precision;
- Support a variety of stimulus type, including RMS, Rapid Stepped Sweep, Precise stepped sine sweep, Multitone, White noise and Pink noise.
- Single sweep measure Frequency Response, Sensitivity (SPL), Distortion (THD), Impedance, F0, Phase, Balance, Polarity, etc.
- Interface for multiple screen can view a variety of test curves;
- All test items are free to be added and deleted;
- Strong saving function, to meet the application requirements of laboratory and production line simultaneously;
- Devices are classified by sensitivity or frequency response frame, the bar code of device can be read;
- Device type can be selected freely, input and output port of instrument can be customized;
- Strong information system make it easier for users to operate the software;
- Various auxiliary functions, such as showing or hiding the testing curve and so on.
1.2 Technical Index

1. **Sweep Signal**
   - **Frequency Range:** generally 20Hz~20kHz, 1~96kHz under particular circumstances
   - **Frequency Error:** < 0.01%
   - **Frequency Band Range:** it can be customized within the frequency range of 20Hz ~ 20kHz
   - **Octave Mode:** 1/3, 1/6, 1/12, 1/24 for choice
   - **Frequency Response:** ≤ ±0.2dB (based on 1kHz)
   - **Level Range:** 50 ~ 5000mV, error ≤ ±0.1dB, distortion< 0.1%
   - **Output Impedance:** 1Ω, 33Ω, 150Ω, 300Ω, 450Ω, 600Ω, 750Ω, 900Ω, 1050Ω

2. **Level Measurement**
   - **Frequency Range:** 20Hz~20kHz
   - **Frequency Response:** ≤ ±0.5dB (based on 1kHz)
   - **Level Range:**
     - Electrical signal measurement: -80dB~10dB (0dB=1V)
     - Acoustic signal measurement: 50dB~140dB (94dB=1Pa)
   - **Measuring error:** ≤ ±0.2dB
   - **Ground noise:** -100dBV

3. **Impedance Measurement**
   - **Frequency Range:** 20Hz~20kHz
   - **Measuring Range:** 1Ω~2000Ω
   - **Measuring Error:** ≤ ±1%

4. **Distortion Measurement**
   - **Frequency Range:** 20Hz~20kHz
   - **Measuring Range:** 0.1~80%

5. **Voltage and Current Measurement of Electrets Microphone**
   - **Voltage Range:** 0 ~ 6.4V ± 50mV
   - **Current Range:** 10 ~ 1000uA
   - **Measuring Error:** ≤ ±1%

6. **Optional Accessories**
   - **Artificial Mouth:** CRY601, CRY602 etc.
   - **Measurement Microphone:** CRY331, CRY332 etc.
   - **Artificial Ear:** CRY318, CRY711
   - **Bluetooth Adapter:** CRY574 Bluetooth Dongle
7. **Multiple Stimulus Type**
   - RMS
   - Rapid Stepped Sweep
   - Precise Stepped Sine Sweep
   - Multitone
   - White Noise
   - Pink Noise

8. **Test Error of Whole Instrument**
   - Errors ≤ ±1dB

9. **Power Supply**
   - 50Hz, 80V～240V ± 10%

10. **Operational Environment**
    - 0～+40°C, relative humidity≤ 80%

11. **Size (mm)**
    - 360×316×161

1.3 Operating Principle

CRY6151 is application software based on Windows XP / Windows 7 operating system, and the whole testing process is mainly controlled by PC in CRY6151. During the electroacoustic devices testing process, users select the corresponding input and output port according to the device, and connect the device after setup the appropriate key parameters in the dialog box. The device such as receiver and headphone shall be connected to the electrical signal output port, and the measurement microphone sends the devices’ sound pressure signal to the input port of acoustic signal to complete the related performance parameters testing for the device; for the device such as microphone, the artificial mouth shall be connected to the output port of artificial mouth, and the incoming sound is converted into electrical signal and sent to the input port of electrical signal by the microphone to fulfill the related performance parameters testing for the device.

1.4 Instrument ports

The appearance of CRY6151 electroacoustic device analyzer is shown in Figure 1.1, and the back panel and each port is defined as shown in figure 1.2.
Left Measurement Microphone Input: connect the left measurement microphone, receive sound signal from the left channel;

Right Measurement Microphone Input: connect the right measurement microphone, receive sound signal from the right channel;

L/R Mic Input: connect the under tested microphone and provide the working voltage required by the microphone simultaneously. Send the received signal to the corresponding channel;

Electrical Signal Input: connect devices like dynamic microphone. Send the received signal to the corresponding channel;

Artificial Mouth Output: connect artificial mouth, as the sound source signal;

Electrical Signal Output: connect devices such as headphone, speaker and loudspeaker;

IO: 8-bit TTL level output, 1-bit trigger signal input;
Part II Driver and Software Installation

This chapter focuses on the installation process of USB, sound card driver and CRY series of software. The above software for each instrument has been installed before leaving the factory. Please refer to the manipulate content in this chapter in case of reinstallation.

2.1 USB Driver Installation

Please follow the steps to install the application software and driver software before using the device:

1. After the equipment is powered on, the task bar of PC will successively pop up the prompt message of “found new hardware” as shown in Figure 2.1, followed by the dialog box of “found new hardware wizard” in the desktop as shown in Figure 2.2. At that moment, select item of “Install from a list or specified location (Advanced)(s)” in the dialog box, and then click next to get the dialog as Figure 2.3.

2. Select the option of "do not search" in the dialog box as shown in Figure 2.3, and click next to enter the dialog box of Figure 2.4.

3. As shown in Figure 2.4, pay attention to the yellow arrows pointing in the Figure. Following the above step of the operation, click the left mouse button to select "install from the disk (H)..." in the dialog box of "found new hardware wizard 2", and the dialog box of "install from the disk" pops up;

4. As shown in Figure 2.4, click the left mouse button to select "browse (B)...", and then the dialog box of "found file" pops up;

5. As shown in Figure 2.4, select "my computer" in the selection bar of "search scope ", and then choose the disk to save the driver installation files;

6. As shown in Figure 2.4, click the left mouse button to select the "open" button;
7. As shown in Figure 2.5, select the CyUSB.inf file in the drive storage directory;
8. As shown in Figure 2.5, double-click the file or click the left mouse button to select the "open" button;
9. As shown in Figure 2.6, click ok to complete the above selection for driver files.
10. As shown in Figure 2.6, return to the "new hardware wizard", and click next;
11. Start to install the driver, and click finish to complete it.

![Figure 2.4 Install Driver from the Disk](image1)
![Figure 2.5 Driver Installation File Selection](image2)
![Figure 2.6 Driver Installation Steps](image3)

2.2 Sound Card Setup

2.2.1 Sound Card Driver Installation

CRY6151 V8.0 uses CRY6138 sound card by default. Find the sound card driver in the software installation package “CRY6138 driver 2014_09_11.rar”, decompress and double click setup.exe. Complete the driver installation according to Figure 2.7. There is no need to input other information in this process. Just click “Install” many times until “Finish”.

![Figure 2.7 Sound Card Installation](image4)
2.2.2 Sound Card Configuration

Click the sound card tray as shown in Figure 2.88, or double click “CRYSoundCpl” in the sound card driver folder to enter into setup interface.

Complete sound card configuration as shown in Figure 2.9.

Notes:

(1) Please be sure to click Apply after selecting sound card setup, to validate the setup.

(2) Please set the sound card after closing test software;

2.3 Driver Installation Inspection

CRY6151 USB is drive-free software and can work normally after powered on. To check if USB and sound card driver are successfully installed, you can operate as follows:

(1) As shown in Figure 2.10, right click “My Computer” on the desktop, select “Manage” to open the “Computer Management” window.
(2) In the left window of “Computer Management”, click “Device Manager”. The interface is as shown in Figure 2.11;

(3) Check the USB driver: expand “Universal Serial Bus Controller” in Device Manager. If there is “CRY6137 USB Controller”, indicates that the USB has been successfully connected;

(4) Check the sound card driver: expand “Sound, video and game controllers” item in Device Manager. If there is “CRY6138 SoundLink84”, indicates that it has been installed successfully. If not, you need to reinstall as shown in Chapter 2.2;

2.4 CRY6151 Software Installation

CRY6151 software is green software and dispenses with installation. Just open CRY6151.exe in the software package.
Part III Software Introduction

3.1 User Management

3.1.1 User Login

When the software is started, “User Login” window pops up, as shown in Figure 3.1. The users are divided into engineers and operators, whether login with a password or not depends on the users. No password is set for the engineers and operators when the software leaves the factory.

![Figure 3.1 Login](image)

Figure 3.1 Login

3.1.2 User Management

After login, the users can freely change the user password by clicking “Setup” on the menu bar, followed by “Change password” to enter the password change interface, as shown in Figure 3.2.

![Figure 3.2 Change Password](image)

Figure 3.2 Change Password

The distinction between “engineer” and “operator” is the different uses-permission, among which the engineer can modify various parameters of the software, while the operator can only operate the basic test functions such as start, stop, save testing and so on.

3.2 Menu Bar Introduction

Software menu item is as shown in Figure 3.3:

![Figure 3.3 Menu Bar](image)
3.2.1 File (F)

The drop-down menu of “File (F)” is as shown in Figure 3.4.

- New (N): build a new sequence, using the suffix.cry;
- Open (O): open an existing sequence, using the suffix.cry;
- Save (S): save the current sequence;
- Save As (A): save as the current sequence;
- Print (P), Print Option (T), Print Rreview(V), Print setup (R): setup associated with the print;
- Exit (X): Exit the software.

3.2.2 Operation (O)

The drop-down menu of “Operation (O)” is shown in Figure 3.5.

- Start: start a single test, by shortcut key F2;
- Cont.: start a continuous test, by shortcut key F3;
- Stop: stop a test, by shortcut key F4;

3.2.3 Calibration (A)

The drop-down menu of “Calibration (A)” is shown in Figure 3.6.

- Calibration (F7): includes Instrument Internal Calibration, Measurement Microphone Calibration and Artificial Mouth Calibration;

3.2.4 Setup (S)

The drop-down menu of “Setup (S)” is shown in Figure 3.7.

- Sequence Editor: set test parameters, including input and output, sensitivity, distortion, balance setup and so on, by shortcut key F5;
- Curve Limits Editor: set curve limits by shortcut key F8;
- Switch User: change the login account;
- Change Password: change the login password;

3.2.5 View (V)

The drop-down menu of “View (V)” is as shown in Figure 3.8.

- New Graph: a new window is used for displaying the test curve;
- Tile Horizontally: tile the curve window horizontally;
- Tile Vertically: tile the curve window vertically;

For window tiling, first of all, sort according to the test steps. Sort windows in the same step by creation or click order. (The last window created or clicked is in the front)
● New Data: display the data that users are concerned about, including frequency response, distortion, impedance, balance and so on, the display item and position which can be freely set;

● Differential Value: display the differential value of sensitivity between the frequency points, it can calculate the differential value of sensitivity in different frequency points at the same test step, or the differential value of sensitivity in different or same frequency points at different test steps;

● Seq. Verdict: this window is used for displaying the sequence's overall pass/fail information.

3.2.6 Curves (C)

The drop-down menu of “Curve s(C)” is as shown in Figure 3.9.

● Frequency Response (FR): add / remove the frequency response curve in the currently active window;

● THD: add / remove the THD curve in the currently active window;

● THD+Noise: add / remove the THD+N curve in the currently active window;

● Rub&Buzz: add / remove the Rub&Buzz curve in the currently active window;

● Rub&Buzz Norm: add / remove the Rub&Buzz Normalized curve in the currently active window;

● Impe.: add / remove the impedance curve in the currently active window;

● Phase: add / remove the phase curve in the currently active window;

● Balance: add / remove the balance curve in the currently active window.

3.2.7 Data (D)

The drop-down menu of “Data (D)” is as shown in Figure 3.10.

● Save Data: save the current test data in the format of JPG or excel file;

● Open Curve: show the saved curve in the currently active curve window;

● Curve List: save and display the test curve in bulk;

● Database Setup: set the data content needs to be saved to the database, including file name, path, sensitivity, impedance and other parameters.

● Enable Save Database: power on / off the Save File function in the database.

● Export Report: set and export the test report in the format of WORD.

3.2.8 Tools (T)

The drop-down menu of “Tools (T)” is as shown in Figure 3.11.

● Self Test: CRY6151 tests hardware by itself;
● Multimeter (M): open a multimeter. Please refer to Section 3.7 for details.
● Signal generator (S): open a signal generator. Please refer to Section 3.8 for details.
● Option (O): set some system parameters of the software, including sequence verdict setup, USB SoundCard setup, etc.

3.3 Sequence and Measurement Step

When starting the software and login for the first time, the program interface is shown in Figure 3.12. The sequence is empty. In the “Home Page” window, users can select “New Sequence”, “Open Sequence”, “User Manual” or “Exit”. The right side of the window shows the latest opened sequences’ list.

The document organization of CRY6151 V8.0 software includes sequence and measurement step. The sequence can contain one or more measurement steps.

Before test, the user needs to perform the following operations (taking a new sequence for example).

Step I: create a new sequence and operate as shown in Figure 3.13. Choose the file path and sequence name.
Step II: only an empty sequence is created when finish the operation of step I, a measurement step has to be added in here. A new measurement step will be prompted to create by default, as shown in Figure 3.14. Input the step name and choose the device type. Click “OK”.

![Create New Measurement Step](image)

Figure 3.14 Create New Measurement Step

Step III: set the test parameters. For detailed test parameter setting, please refer to software setup in Chapter 4.

![Test Parameters Setup](image)

Figure 3.15 Test Parameters Setup

3.4 Instrument Calibration

Open mode: select the “Calibration (A)” → “Calibration F7”, or right click the curve interface to select “Calibration”. Figure 3.16 pops up.

![Instrument Calibration](image)

Figure 3.16 Instrument Calibration
3.4.1 Instrument Internal Calibration

Click “Instrument Internal Calibration”, until “Calibration Passed” or “Calibration Failed” is prompted. If “Calibration Failed” is prompted, please check the line connection.

3.4.2 Measurement Microphone Calibration

![Connection Diagram of Left Microphone](image)

Figure 3.17 Connection Diagram of Left Microphone

Calibrate the left measurement microphone, and the connecting line is shown in Figure 3.17. The calibration data is as shown in Figure 3.16. The value is closely related to the type of microphone. If the value is obviously smaller than normal, you have to check whether the CRY6151 sound level calibrator is powered, the power is enough, or the line is well connected and so on.

If necessary, calibrate the right microphone with the same method as the left microphone calibration, and the only need to note is to connect the right microphone to the right microphone input port (MIC 2).

If you know the sensitivity of microphone, you can also enter the sensitivity value manually.

3.4.3 Artificial Mouth Calibration

When choosing artificial mouth output, artificial mouth calibration is necessary. CRY6151 system has two artificial mouth output ports. According to real connection choose Mouth 1 or Mouth 2 for calibration. The actual calibration frequency is the selected measurement step’s frequency range.
Taking “Mouth 1 Calibration” as an example, click “Mouth 1 Cal.” and the window shown in Figure 3.19 pops up.

**Note:** Use the left measurement microphone for Mouth calibration only.

- Test Level: target sound pressure, calibrate the artificial mouth to a sound pressure level, such as 94dB;
- Lowest Freq. and Highest Freq.: the start and stop frequency points of calibration;
- Max. Deviation: criterion for judging whether the calibration is completed, the calibration will automatically stop when the deviation between the calibration curve in the start-stop frequency range and the target pressure is less than the “Max Deviation of Calibration”, complete the calibration;
- Start: click this button to start the calibration;
- Stop: click this button to stop the calibration constrainedly;
- Restore: reset the calibration data to factory default;
- Exit: when exiting the calibration, the software will prompt whether to save the calibration result.

![Figure 3.19 Artificial Mouth Calibration](image)

### 3.5 Interface Display

#### 3.5.1 New Graph

Curve window is a module to show the various curves, a curve window can display a plurality of test curves.

Open mode: menu bar “View (V)” → “New Graph”, tool bar “New Graph” button, or right-click select the “New Graph”;

After clicking the new graph, “New Curve” window will pops up, as shown in Figure 3.20, explaining as follows.

**Step Name:** select the measurement steps for the new curve to be built;
**Curve Type Option:** it has multiple curve types for selection, including SPL, THD, THD+Noise, Rub&Buzz, Rub&Buzz Norm, impedance, phase and balance. But only curves highlighted can be selected for the users, the rest items are shielded. Users can highlight the curves by adding required test items in the sequence editor.

Users can also add a curve display type in the existing curve window. Operation mode: click and select a curve window need to be added. After that, select the category and channel to be displayed in the “Curves” of the menu bar, as shown in Figure 3.21.

Create a new graph and add the L Channel of frequency response curve. The effect is shown in Figure 3.22.

![Figure 3.21 Add Curve](image)

Figure 3.21 Add Curve

Create a new graph and add the L Channel of frequency response curve. The effect is shown in Figure 3.22.

![Figure 3.22 The Effect of Adding Curve](image)

Figure 3.22 The Effect of Adding Curve

The curve window can be customized according to customer’s needs, as follows:

1. **Chart Property**

   Double click the left mouse button on the graphical interface. The “Chart Property” window will pops up, as shown in Figure 3.23.

![Figure 3.23 Chart Property](image)

Figure 3.23 Chart Property

![Figure 3.24 Modify Axis Parameters](image)

Figure 3.24 Modify Axis Parameters
- Chart: modify the background color and pane color of a graph;
- Axis: modify the text color and line color of coordinate axis;
- Legend: control the display of legend, horizontal alignment or vertical alignment;
- Title: control of the display, color and text content of title.

(2) Axis Parameter Setting

Double click a coordinate endpoint to be modified. The coordinate axis scope can be modified. After the value is modified, click anywhere else to confirm the modification. Modify the minimum of Y-axis as shown in Figure 3.24.

(3) Curve Setup

Double click the curve or the name on the legend, modify curve parameters, as shown in Figure 3.25.

(4) Graphic Scrolling and Zooming

Left click to select the curve window, roll the middle mouse button to scroll the curve graph up and down. Hold down Ctrl key while rolling the middle mouse button to zoom the curve graph.

(5) Curve Addition Principle

Two Y-axis units at most can be added to a curve window, docked in the left and right side of the window respectively, as shown in Figure 3.26. If the user continues to add a third set of Y-axis, impedance curve for example, a prompt window as in Figure 3.27 will pop up.
(6) Cursor Display

Right click the curve window. There are “Show Cursor” and “Fix Cursor” options on the right-click menu.

**Show Cursor:** When it is selected, two cursor values will be displayed on the upper left corner of graph and two cross cursors will be displayed on the curve, as shown in Figure 3.28. Selecting the cursor and hold down the left mouse button, to drag the cursor arbitrarily, or move the cursor left or right using left or right arrow keys on the keyboard, switch the cursor curve using up or down arrow keys.

**Fix Cursor:** Disable the cursor drag function of the left mouse button. Arrow keys on the keyboard are still usable.

3.5.2 Arrange Curve Window

The software allows tiling the curve windows, either Tile Horizontally or Tile Vertically. The effect is shown in Figures 3.29 and 3.30.

**The order of windows:**

(1) Divide the area according to measurement steps. Curve windows in different steps won’t overlap.

(2) Windows in the same test step are sorted by a reverse order to mouse clicked. Namely, the last window clicked before the curve distribution button is clicked will appear in the forefront of step window.

![Figure 3.28  Cursor Display](image)

![Figure 3.29  Tile Horizontally](image)
3.5.3 New Data

Open mode: menu bar “View (V)” → “New Data”, tool bar “New Data” button, right-click select the “New Data” or shortcut key F10;

After clicking the new data, “New Data” window will pops up, as shown in Figure 3.31. Options of the “New Data” window are described as follows:

- **Step Name**: the sequence may have multiple test steps, so the corresponding test step shall be selected when creating a “New Data”;

- **Dock Position**: set the initial position of “New Data” docked in the interface, which is divided into left and right. It can be freely dragged after added.

- **Content**: select the contents of the data to be observed, including the frequency response, THD, impedance, balance and so on. The left side of the window will display the items being tested which are automatically recognized. Users only need to choose data items to be displayed and complete the choice with the right shift button. The right side shows the selected data items to be displayed. Click “OK” and complete the addition of data window. Right click the data area in the blank. A corresponding setup menu will pop up, as shown in Figure 3.32.

  - **Add**: click the right mouse button in different category positions, to add frequency and test content of corresponding categories. For example, click on the right-click menu of the “Frequency response (L)”, the frequency, average frequency response and curves limits verdict, etc. can be added.

  - **Delete**: delete a selected data;
- Set Range: set the limits of a selected data;
- Category Management: add or delete a data category in the existing data window, as shown in Figure 3.33;
- Expand All: expand all data items;
- Collapse All: collapse all data items;

![Right-click Menu of Data Window](image1)

![Category Management of Data Window](image2)

After the end of test steps, data in the data window will be refreshed, to determine whether the content passes. If pass, the background color will be pass color. If fail, the background color will be fail color. The verdict color is set in “Tools”→“Option”→“Verdict”.

For example, the pass display mode is shown in Figure 3.34 when data items are expanded or collapsed respectively. When the items are collapsed, a sequence verdict in a certain category will be displayed.

![An Example of Data Verdict](image3)

The bottom of the data window shows whether the whole data window is judged as pass.

In the data window, double click a corresponding line (Row 1), a setup interface will pop up. For example, double click 1k, and the “Correction and Limits” window will pop up. This feature greatly facilitates the user’s correction of set values.

Below, data that can be added and displayed in each category are listed briefly (on the premise that all test items are added):

- Frequency Response L/R: Frequency Response Value, Average Frequency Response, Curves limits, Frequency Response Grade and Curves limits Grade of each frequency point;
- THD L/R: THD value and curves limits of each frequency point;
- THD+Noise L/R: THD+Noise value and curves limits of each frequency point;
- Rub&Buzz L/R: Rub&Buzz value and curves limits of each frequency point;
- Rub&Buzz Normalize L/R: Rub&Buzz Normalize value and curves limits of each frequency point;
- Impedance L/R: impedance value, curves limits and TS parameters of each frequency point;
- Phase L/R: phase value and curves limits of each frequency point;
- Balance: balance value, balance of average frequency response and curves limits of each frequency point;
- Other L/R: delay time, left or right position, polarity, Mic voltage and Mic current, etc.

3.5.4 Status Bar

The bottom of the whole program shows the status bar of program, which displays the test state, test time, storage location of the current sequence, current S/N and whether data will be stored in the database automatically, as shown in the figure below.

![Figure 3.35 Status Bar](image)

3.5.5 Sequence Verdict

Click “View (V)” → “Sequence Verdict” on the menu to display or hide the sequence verdict.

The sequence verdict is used to display the general test result or test state. Select the sequence verdict and hold down the left mouse button to move the window to any position. When opened next time, the window will restore to the position when the program is last closed.

Menu bar “Tools”→“Option”→“Verdict”, the font, color and other attributes of the verdict window can be set. Please refer to 4.14.1 for details.

3.5.6 Differential Value

Differential Value is used to calculate the difference between the specified test steps and sensitivity of frequency point, especially suitable for testing the directional microphones.

Click the “Differential Value” under “View” in the menu bar, the Differential Value window will pop up on the top of the Curve Interface, and right click the “Setup” in this window to modify the differential value setup, which is divided into two attribute pages.

- Differential Value setup is as shown in Figure 3.36 (L):

![Figure 3.36 Differential Setup](image)

- Select step and the frequency points involved in the calculation by the drop-down menu, the differential value
data equals to the sensitivity value of the first solution frequency points minus the sensitivity value of the second solution frequency points.

- Limits: set a qualification range. It is acceptable when the differential value is between the lower and higher limit, shown as PASS color in “Differential Value”; otherwise it is shown as Fail color;
- Add or Delete: add or delete differential value in the differential value list. The software calculates all differential values in the list.

* Save setup is as shown in Figure 3.36 (R):
  - File Name: file name can be selected between the current date and custom;
  - File Path: select a file path with a browse button
  - Start Number: it defaults to be the ordered of the end of the file. Namely, continue to the last serial number of the file last saved, and it also can be customized;
  - Auto Save: tick √ to represent to save differential value for each sweep frequency;

3.6 Instrument Self Test

Open mode: select the “Self Test” under “Tools” in the menu bar, and Figure 3.37 (L) pops up. Click the the “Start Self Test” button and wait for a moment. Green indicates that the instrument’s self test is pass, while red is fail, pass is as shown in Figure 3.37(R).

![Figure 3.37 Instrument Self Test](image)

3.7 Multimeter

Open mode: “Tools” →“Multimeter” in the menu bar, Figure 3.38 pops up.

Signal Path: Standard Mic (L), Standard Mic (R), Line in (L), Line in (R).

Set a period of time, calculate the level value (RMS) of signals acquired in this period and display it in the Input Level text box.
3.8 Signal Generator

Open mode: “Tools” → “Signal Generator” in the menu bar, Figure 3.39 pops up.

Signal Type: sine Wave, Wav files.

When selecting sine Wave, users have to set the frequency and level in the output text. Otherwise selecting Wav files, users have to select Wav file path on the disk to play this file.

Output Port: Electric output (L), Electrical output (R), Electric output (L&R) and Mouth output. Set the output port of signals.

When selecting sine Wave signals and artificial mouth output, users can also select “EQ”, i.e., calibrated sound pressure signal. Users select a calibration file and set the output level.
Part IV Software Setup

4.1 Sequence and Measurement Step

A Sequence is a list of tests, with the suffix .cry. A sequence may contain one or more test steps, while a step is the basic unit of tests. For example, a sequence of headphone with microphone generally contains headphone test step and microphone test step.

The creation and save of a sequence are done in the “File” on the main menu. Don’t create or delete any file in the sequence folder, otherwise unknown error may occur in the sequence.

“Setup” → “Sequence Editor” (shortcut key F5) in the menu bar. Open the sequence editor.

Description of six functional buttons on the upper left corner of sequence editor:

- **Add Step**: click the “Add Step” button and choose the step type. The step types include Measurement, Message, Extrigger, S/N, Serial Ports IO Code, Bluetooth, Jump and Custom. The measurement as means step. So in the following we named step as measurement, other step types are called auxiliary steps. Every type will be explained in detail in the next chapter.

- **Load Step**: click the “Load Step” button and load an existing measurement. The existing measurement must be put in the file directory of sequence.

- **Delete**: delete a selected step.

- **Move Up, Move Down**: move the step up or down, adjust the test order.

- **Add Item**: add a sub item to the test step. According to different device types, different test items can be selected. All test items will be displayed when the custom is selected. The sequence will test the items which is ticked.
4.2 Measurement

After selecting Measurement, Figure 4.3 pops up. The user can input the step name and device type. Choose different device types, the software will show different setup contents.

Device Type: receiver, headphone, speaker, electret mic, dynamic mic, mems. mic, USB headphone, bluetooth headphone, USB mic, bluetooth mic and custom.

- **Receiver, Headphone and Speaker**: the output port is fixed Headphone output. The input port is fixed on standard MIC input. The output type can be open-circuit voltage or device excitation voltage. Frequency response, THD, Rub&Buzz, impedance, phase, polarity and other parameters can be tested.

- **Electret Mic (MIC), Dynamic Microphone and Mems. Mic**: The output port is fixed on Mouth output. The electret mic and mems. mic input ports are especially for DUT MIC input. The dynamic mic input is fixed on Line In port. Frequency response, THD, Rub&Buzz, phase, polarity and other parameters can be tested. The electret mic can also test Mic current.

- **USB Headphone and Bluetooth Headphone**: the output port is fixed on USB SoundCard. The sampling signal is 48kHz and 16-bit digital signals. When choosing a USB headphone, you need to choose a soundcard name in “Tools”→“Option”→“USB SoundCard”. If the instrument is only connected to a USB soundcard device, the only USB SoundCard will be selected as the tested sound card. When choosing a bluetooth headphone, CRY574 bluetooth Dongle will be used as the USB SoundCard. Meanwhile, it is necessary to add “Bluetooth” auxiliary step before the measurement to connect to a bluetooth headphone. The input port is fixed on MIC input.

- **USB Mic and Bluetooth Mic**: the output port is fixed on Mouth port. The input port is fixed on USB mic sound card.

- **Custom**: at this time, the input, output and test content are no longer limited. The user can set each parameter freely. This type has the most test items. This chapter takes custom device type as an example and adds all test items (only test items whose check boxes are ticked are valid).

4.2.1 Input & Output

The setup interface is shown in Figure 4.4.

(1) Output Setup

- **Output Port**: Electric Output, Mouth Output and USB Headphone. L, R or L/R channel can be chosen for Electric Output and USB Headphone Output. Mouth 1 or Mouth 2 can be chosen for Artificial Mouth Output.
Output Type: Mouth Voltage, Open-circuit Voltage and Excitation Voltage.

- **Mouth Voltage**: it is to add the sound pressure of equalizer after artificial mouth calibration. The output level can be Pa RMS or dB re 20uPa. 1Pa RMS is equal to 94dB re 20uPa;
- **Open-circuit Voltage**: refers to output voltage when the circuit is open, generally used for electrical signal output and USB headphone output, as shown in V in Figure 4.5;
- **Excitation Voltage**: refers to voltage actually loaded on opposite sides of the device, as shown in V1 in Figure 4.5. The calculation principle and formula are shown in Figure 4.5 and Formula 4.1;

- **Output Impedance**: select the value of the circuit internal series resistor impedance, as shown in R1 in Figure 4.5;
- **Nominal Impedance**: actual impedance of device, as shown in R2 in Figure 4.5.

![Output Impedance Diagram](image)

Figure 4.5 Description of Output Voltage Circuit

\[ V1 = V \times \frac{R2}{R1+R2} \] (4.1)
(2) Stimulus:


Among them, when testing Rub&Buzz, THD+Noise and Rub&Buzz Norm, it is necessary to choose Precise Stepped Sine Sweep algorithm. The test contents of different stimulus algorithms are shown in Table 4.1.

<table>
<thead>
<tr>
<th>Test Content</th>
<th>Frequency Response</th>
<th>THD</th>
<th>Rub&amp;Buzz</th>
<th>Impedance</th>
<th>Phase</th>
<th>Polarity &amp; Position</th>
</tr>
</thead>
<tbody>
<tr>
<td>RMS</td>
<td>✓</td>
<td>✓</td>
<td>✓</td>
<td>✓</td>
<td>✓</td>
<td>✓</td>
</tr>
<tr>
<td>Rapid Stepped Sweep</td>
<td>✓</td>
<td>✓</td>
<td>✓</td>
<td>✓</td>
<td>✓</td>
<td>✓</td>
</tr>
<tr>
<td>Precise stepped sine sweep</td>
<td>✓</td>
<td>✓</td>
<td>✓</td>
<td>✓</td>
<td>✓</td>
<td>✓</td>
</tr>
<tr>
<td>Multitone</td>
<td>✓</td>
<td>✓</td>
<td></td>
<td>✓</td>
<td></td>
<td></td>
</tr>
<tr>
<td>White noise and Pink Noise</td>
<td>✓</td>
<td>✓</td>
<td></td>
<td></td>
<td></td>
<td></td>
</tr>
</tbody>
</table>

- Octave Mode: 1/3, 1/6, 1/12, and 1/24 for choice
- Start, Stop Frequency Sweep: set the sweep range.

(3) Input Setup

- Input Port: choose one from standard MIC, DUT MIC, Line In or USB MIC.
- Test Channel: L (L Channel), R (R Channel), L/R (left or Right Channel).
- Sound Range: set the input range of standard mic signals. The range value set shall be greater than and close to the maximum value of the actual measurement sensitivity curve.
- Voltage Range: set the input range of microphone or electrical signals. The range value set shall be greater than and close to the maximum value of the actual measurement sensitivity curve.
- Reference Pressure: select the reference pressure 20uPa, 1Pa, commonly used 20uPa.

Note: For the convenience of the user, software has corresponded the device type with the Input & Output port. For example, the port will be defaulted as MIC input, HP output respectively and the setup Interface will no longer display port selection when the user chooses device type as Headphone. Please select the custom device type for a special device.

4.2.2 Frequency Response

The frequency response test item completes the correction of frequency response and the limits of a single point. The interface is shown in Figure 4.6:

- Overall Correction: add a correction value to every frequency point on the curve;
- Points Correction and Limits: realize the correction of single frequency points, while setting the limits of this point.
- Standard Curve Correction:
  - Standard Curve: read and subtract data in the test curve file from data in the standard curve file, to get the data
correction value. It is required that frequency points in two data files should be identical and consistent with frequency points in the current test step.

- Test Curve: click the “Test” button and “Actually Tested Average Curve” window will pop up. Input N in the text box of “Continuous Test Times”, calculate the average curve as a correction curve and save it as a file.

- Curve Smooth (times)

![Curve Smooth](image)

Figure 4.6 Frequency Response Setup

**Note:** The setup method of left and Right Channel is the same. The software supports mutual copying setup items between left and Right Channels.

### 4.2.3 Average Frequency Response

- The calculation of average frequency response

  - Based on upper and lower limits of frequency sweep: calculate average frequency response according to the upper and lower limits of frequency sweep set by the user;
  
  - Select upper and lower limits: calculate average frequency response according to start and stop frequency sweep set by the user;
  
  - Select frequency points: calculate average frequency response according to several frequency points set by the user;

- The setup of L/R average frequency response correction value, as well as limits, can be set freely in the table.
Note: The calculation of average frequency response is done with logarithmic algorithms.

4.2.4 Frequency Response Grade

Frequency response grade includes Points Limits Grade and Curves limits Grade (curves limits). The interfaces are shown in Figures 4.8 and 4.9.

(1) Points Limits Grade

- Add and delete frequency points involved in grade verdict. They can be multiply selected with ctrl key.
- Grade Setup: classify the sensitivity value of frequency points on the measured curve involved in the verdict.

The grade result will be displayed in the data observation window, path of “Frequency Response” → “Frequency response grade”.

(2) Curves Limits Grade: Curves limits Grade refers to the N set curves limits. Carry out the intersection verdict between the N curves limits and the actual test curves, they are determined to fall in this curves limits if they don't intersect, and the grade results will be displayed within the “Curves limits Grade” under the “Decision Item” in the observation window, displaying the numerical value as 0-N, among which “0” represents “measured curve”, while “N” stands for “user defined N”. Displaying “None” expresses the measured curve doesn't fall in any of the curves limits. **Note: Curves Limits Grade only applies to the “Absolute Limits” or “Floating Data” method.**

So generally requirements for top classes are stricter, such as the offset of Class 1 is ±1, the offset of Class 2 is ±2, the offset of Class 3 is ±3...The grade result is the first set of curves limits that meet the requirements of grade.
Grade Name: name defined by the user. You can add, delete, move up or down the grade.

Fit Points: calculate the curves limits according to the offset, using Fit Points

Copy>>, copy<<: copy the frequency and offset of upper and lower curves limits

Clear: clear the list of upper and lower offsets

Update one: refresh the grade curves limits on the graph

L/R Same Grade: when ticked, the left and Right Channels use Curves limits Grade data in the L Channel. When not ticked, the left and R Channels use respective grade data independently;
✓ Update All: update all grade data, especially when the test curve is retested. All grade curves limits can be refreshed.
✓ Reference Frequency and Reference Value: the reference frequency and reference value of curves limits are consistent with parameters set in the curves limits.

4.2.5 Balance

When L/R is selected as the input port, the balance can be calculated by subtracting the right frequency response from the left frequency response.

![Balance Setup](image)

Figure 4.10  Balance Setup

✓ Points Upper Limit: single-point verdict of balance. If the absolute value of the balance of a single point is less than or equal to the upper limit, it shall be judged as pass. Otherwise, it fails.
✓ Average Balance: i.e., the upper limit of the absolute value of the difference between the average sensitivity of the L Channel and that of the right channel.

4.2.6 THD

THD is the same as total harmonic distortion.

(1) Harmonics and Range: set the harmonic order of THD. Generally, THD harmonic components are in 2nd and 3rd harmonics, so just choose 1, 2 and 3. The start and stop frequency is the frequency range of THD.
(2) Correction Method: for THD correction, adding or multiplying correction values can be selected.
(3) Overall Correction: the total correction value of THD curve.
(4) Points Correction: the correction value and upper limit of THD single point.

Note: The setup method of left and right Channels is the same. The software supports mutual copying between setup items in the left and right channels.
4.2.7 Impedance

(1) Overall Correction: the total correction value of impedance curve.

(2) Points Correction and Limits: add, delete or modify the correction value and limits of any frequency point;

**Note:** The setup method of left and R Channels is the same. The software supports mutual copying between setup items in the left and right channels.

4.2.8 F0 and Q Value

The results of F0, Q value and other test parameters are shown in “Impedance” in the data observation window. The interface is shown in Figure 4.14. The detailed setup is as follows:

(1) Direct Calculation: calculate F0 by looking for the maximum of impedance curve;
(2) Binomial Fitting: calculate the maximum of impedance curve through binomial fitting. The ultimate F0 value is not necessarily a frequency point in the sweep frequencies.

(3) Start and Stop Frequency of F0: look for or calculate the frequency range of F0.

(4) Various Parameters: Rac refers to AC impedance corresponding to the first minimum after F0 frequency point on the impedance curve. Zm refers to AC impedance of a corresponding frequency point on the impedance curve. RΔ refers to the difference between Zm and Rac. Qm is the mechanical quality factor. Qt is the total quality factor.

4.2.9 Mic Current

The setup of Mic current is as follows:
(1) The setup of mic voltage and current-limiting resistance: set the required operating voltage DCV and current-limiting resistance DCR. The voltage can be set between 0-6V. The resistor comes in 8 common resistance values for choice.

**Note:** Before clicking the “Apply” button, it is necessary to disconnect the tested microphone.

(2) Mic Limits Setup: set the limits of Mic current and voltage.

### 4.2.10 Phase

<table>
<thead>
<tr>
<th>Custom &gt; Phase</th>
</tr>
</thead>
<tbody>
<tr>
<td>Left Channel</td>
</tr>
<tr>
<td>□ Total Correct 0 deg</td>
</tr>
<tr>
<td>□ Points Correct and Limits</td>
</tr>
<tr>
<td></td>
</tr>
<tr>
<td>Right Channel</td>
</tr>
<tr>
<td>□ Total Correct 0 deg</td>
</tr>
<tr>
<td>□ Points Correct and Limits</td>
</tr>
<tr>
<td></td>
</tr>
</tbody>
</table>

**Figure 4.16** Phase Setup

(1) Overall Correction: the total correction value of phase curve.

(2) Points Correction and Limits: the correction value and limits of phase single point.

**Note:** The setup method of left and right channels is the same. The software supports mutual copying setup items between the left and right channels.

### 4.2.11 Loudness Verdict

The setup interface of loudness verdict is shown in Figure 4.18. In this table, a variety of many loudness verdict items can be corrected and the limits can be set.

Loudness verdict items include Receive Loudness Rating (RLR), Send Loudness Rating (SLR), Weighted Terminal Coupling Loss (TCLW), Sidetone masking rating (STMR), Send idle noise (Tx Noise) and Receiving idle noise (Rx Noise).

**Figure 4.17** A List of Loudness Rating Items
(1) **Receive Loudness Rating (RLR)**

The calculation formula is as follows:

$$RLR = -\frac{10}{m} \cdot \lg \sum_{4}^{17} 10^{\frac{m}{10}(S_{j}-W_{R})}$$  \tag{4.2}

$W_{R}$—The weighting coefficient of RLR. The $W_{R}$ of different frequencies are shown in Table 4.2;

$m$— The slope coefficient, $m= 0.175$;

(2) **Send Loudness Rating (SLR):**

The calculation formula is as follows:

$$SLR = -\frac{10}{m} \cdot \lg \sum_{4}^{17} 10^{\frac{m}{10}(S_{m,j}-W_{S})}$$  \tag{4.3}

$S_{m,j}$—The frequency response of tested frequency point

$W_{S}$—The weighting coefficient of SLR. The $W_{S}$ of different frequencies are shown in Table 4.2;

$m$— The slope coefficient, $m= 0.175$;

(3) **Weighted Terminal Coupling Loss (TCLW)**

The calculation formula is as follows:

$$TCLW = HCLW - (RLR + SLR) + 8$$  \tag{4.4}

$HCLW$: The tested frequency response of microphone. The calculation method is the same as SLR;

(4) **Sidetone Masking Rating (STMR):**

The calculation formula is as follows:

$$STMR = -\frac{10}{m} \cdot \lg \left(\sum_{1}^{20} 10^{\frac{m}{10}(S_{maxST}-W_{m})}\right)$$  \tag{4.5}

$W_{m}$—The weighting coefficient of STMR. The $W_{m}$ of different frequencies are shown in Table 4.3;

$m$— The slope coefficient, $m= 0.225$;
Table 4.2  The Weighting Coefficient of Loudness Rating

<table>
<thead>
<tr>
<th>Frequency Band No.</th>
<th>Center Frequency Hz</th>
<th>Weighting Coefficient of RLR Wsi</th>
<th>Weighting Coefficient of SLR Wri</th>
<th>Earpiece Leakage Coefficient LE</th>
</tr>
</thead>
<tbody>
<tr>
<td>4</td>
<td>200</td>
<td>76.9</td>
<td>85.0</td>
<td>8.4</td>
</tr>
<tr>
<td>5</td>
<td>250</td>
<td>62.6</td>
<td>74.7</td>
<td>4.9</td>
</tr>
<tr>
<td>6</td>
<td>315</td>
<td>62.0</td>
<td>79.0</td>
<td>1.0</td>
</tr>
<tr>
<td>7</td>
<td>400</td>
<td>44.7</td>
<td>63.7</td>
<td>-0.7</td>
</tr>
<tr>
<td>8</td>
<td>500</td>
<td>53.1</td>
<td>73.5</td>
<td>-2.2</td>
</tr>
<tr>
<td>9</td>
<td>630</td>
<td>48.5</td>
<td>69.1</td>
<td>-2.6</td>
</tr>
<tr>
<td>10</td>
<td>800</td>
<td>47.6</td>
<td>68.0</td>
<td>-3.2</td>
</tr>
<tr>
<td>11</td>
<td>1000</td>
<td>50.1</td>
<td>68.7</td>
<td>-2.3</td>
</tr>
<tr>
<td>12</td>
<td>1250</td>
<td>59.1</td>
<td>75.1</td>
<td>-1.2</td>
</tr>
<tr>
<td>13</td>
<td>1600</td>
<td>56.7</td>
<td>70.4</td>
<td>-0.1</td>
</tr>
<tr>
<td>14</td>
<td>2000</td>
<td>72.2</td>
<td>81.4</td>
<td>3.6</td>
</tr>
<tr>
<td>15</td>
<td>2500</td>
<td>72.6</td>
<td>76.5</td>
<td>7.4</td>
</tr>
<tr>
<td>16</td>
<td>3150</td>
<td>89.2</td>
<td>93.3</td>
<td>6.7</td>
</tr>
<tr>
<td>17</td>
<td>4000</td>
<td>117.0</td>
<td>113.8</td>
<td>8.9</td>
</tr>
</tbody>
</table>
### Table 4.3  The Weighting Coefficient of STMR

<table>
<thead>
<tr>
<th>Frequency Band (i)</th>
<th>Center Frequency (f_i) (Hz)</th>
<th>Weighting Coefficient of STMR (W_{NSI})</th>
</tr>
</thead>
<tbody>
<tr>
<td>1</td>
<td>100</td>
<td>110.4</td>
</tr>
<tr>
<td>2</td>
<td>125</td>
<td>107.7</td>
</tr>
<tr>
<td>3</td>
<td>160</td>
<td>104.6</td>
</tr>
<tr>
<td>4</td>
<td>200</td>
<td>98.4</td>
</tr>
<tr>
<td>5</td>
<td>250</td>
<td>94.0</td>
</tr>
<tr>
<td>6</td>
<td>315</td>
<td>89.8</td>
</tr>
<tr>
<td>7</td>
<td>400</td>
<td>84.8</td>
</tr>
<tr>
<td>8</td>
<td>500</td>
<td>75.5</td>
</tr>
<tr>
<td>9</td>
<td>630</td>
<td>66.0</td>
</tr>
<tr>
<td>10</td>
<td>800</td>
<td>57.1</td>
</tr>
<tr>
<td>11</td>
<td>1000</td>
<td>49.1</td>
</tr>
<tr>
<td>12</td>
<td>1250</td>
<td>50.6</td>
</tr>
<tr>
<td>13</td>
<td>1600</td>
<td>51.0</td>
</tr>
<tr>
<td>14</td>
<td>2000</td>
<td>51.9</td>
</tr>
<tr>
<td>15</td>
<td>2500</td>
<td>51.3</td>
</tr>
<tr>
<td>16</td>
<td>3150</td>
<td>50.6</td>
</tr>
<tr>
<td>17</td>
<td>4000</td>
<td>51.0</td>
</tr>
<tr>
<td>18</td>
<td>5000</td>
<td>49.7</td>
</tr>
<tr>
<td>19</td>
<td>6300</td>
<td>50.0</td>
</tr>
<tr>
<td>20</td>
<td>8000</td>
<td>52.8</td>
</tr>
</tbody>
</table>

#### 4.2.12 Output Code

Complete output coding in the output code of the test step, as shown in Figure 4.19. In the IO of auxiliary steps, which items will be output through IO will be determined. Two parts complete IO output code together.

The pass/fail code, Frequency Response Grade code, Curves limits Grade code of test items can be set. The codes are 8-bit binary numbers (0 or 1), corresponding to 8 pins on IO port. “1” stands for high level (5V) and “0” stands for low level (0V).
4.2.13 Other Setup

(1) Polarity Test

When polarity is tested, tick the check box of “Polarity”. Polarity Test includes “Correlation” and “Pulse” method.

When custom is selected, users can set verdict symbols arbitrarily. When choosing “same symbol”, the left and right are “+” or “-”, it shall be judged as pass.

(2) L/R Position

Tick the check box of “L/R Position”, the L/R position of device can be tested. At this moment, the input port of “input
and output” must be “L+R”.

(3) Delay time

set the limits of delay time;

4.3 Message

Choose “Message” in the steps. The dialog box of “Message Setup” will pop up. The delay time can be set. The message character to be displayed can be edited. For example, set message as shown in Figure 4.21. When the sequence tests to the step of message, “Message” shown in Figure 4.22 will pop up. Waiting for three seconds to exit automatically, or click “OK” to jump out of the message window in advance manually.

![Message Setup](image)

**Figure 4.21** Message setup

**Figure 4.22** Message Prompt Box

4.4 Extrigger

In the steps, choose “Extrigger” and the dialog box of “Extrigger Setup” in Figure 4.23 will pop up. Footswitch trigger or impedance trigger can be selected.

(1) Footswitch Trigger: Footswitch trigger in the IO input port, testing the low level trigger signal. When footswitch is always on, the test will be on and on.

(4) Impedance Trigger: Detect the impedance signal in the electrical signal output port. When a device is connected, a test will be triggered. Impedance trigger requires that the step must allow impedance test, and the output impedance must be as close to the impedance of tested device as possible.

![Extrigger Setup](image)

**Figure 4.23** Extrigger Setup

**Figure 4.24** Extrigger Display Interface

4.5 Serial Number

In the steps, choose an S/N. The dialog box of “S/N Setup” will pop up. When the S/N set by the user is a pure integer and increases automatically, every time the sequence proceeds to this step, the S/N will increase by 1 automatically.

In the dialog box of “S/N Display”, the number can be displayed according to the set S/N, or input manually. Click “Start Test” to test, and click “Exit Test” to stop the sequence test.
4.6 Serial Port

The serial port supports communicating with serial ports in peripheral devices (e.g., PLC) and software. The input and output supports two modes, hexadecimal and text. Users can choose serial port input or output automatically.

- Serial Port Input: when proceeding to the serial port step, a waiting prompt window will pop up and wait for serial port command. When the received serial port commands include set specified command, the program will go to the next step. As shown in the figure, wait for the text “Start”. When the serial port receives the “Start” string, the program will go to the next step (note: including relationship, such as “Start” and “Start1”, etc.).

**Note:** In serial port input, the test data or verdict results can also be obtained according to CRY6151 serial port communication command. The specific commands are shown in Appendix 1 (CRY6151 serial port communication command). In serial port waiting, the set text should be different from the specified serial port command as far as possible.
Serial Port Output: when proceeding to the serial port step, according to the set sequence verdict result, different strings are output. When selecting text (non-hexadecimal), you can choose “sending a new row”. At the end of text, add a carriage return and line feed (“\r\n”). To output a character string fixedly, you can select both “send when pass” and “send when failed”. Just set character strings to be output in the corresponding text.

4.7 IO Code

![IO Code Output Setup](image)

In this step, an IO code will be output, as shown in Figure 4.29. The coding sequence is D7 D6 D5 D4 D3 D2 D1 D0. The IN pin is a Extrigger switch and the low level is effective. The code output ‘0’ stands for low level and ‘1’ stands for high level (3.3V).

- Fixed Output: when the fixed output is ticked. The IO port will output a fixed code;
- Sequence Verdict Output: when the sequence verdict is ticked, according to passed or failed sequence verdict, codes output by the step are added for output.
- Step Output: Each test item can output code according to pass or fail. The code is set in the “output code” of the step. The output code is the sum of codes in each step (“OR” relationship). If the sequence verdict output is ticked, the code of sequence verdict must be added, too (“OR” relationship).

4.8 Bluetooth

This step is used when testing a bluetooth device. Only one device can be added in this step and it has globality. After setup, both bluetooth headphone and bluetooth mic in the sequence will use setup in this step. So this step should be put before bluetooth headphone and bluetooth mic test.
CRY574 Bluetooth Dongle is used for pairing, which is developed by our company independently. It is featured with quick pair speed, easy use and stable connection, etc. When Dongle is successfully connected, the name “CSR Audio Dongle” will be displayed in the sound card.

“Bluetooth” in the test steps is a setup interface. The Bluetooth test interface is in the main interface window. If the original window is not opened, when proceeding to this step, the window will be displayed, as shown in Figure 4.30.

4.8.1 Pair Mode

There are three bluetooth pair modes: Search, Auto and MAC Address. Among them, search pair is essentially a pairing of MAC address. Three kinds of “Pair Modes” setup are shown in Figure 4.31, explained in detail below:

(1) Search Pair: when the software begins to test, it will send an automatic search order to CRY574, which returns the searched device name, RSSI power value and MAC address of bluetooth device. When ticking “Device Name Pair”, the software will compare the searched device name. When the device name contains the set name, the device’s MAC address is used for pair. When ticking “Pair by RSSI value”, the software will compared the searched devices’ RSSI Value. When the value exceeds the set RSSI lower limit, the device’s MAC address will be used for pair. If both of them are ticked, then two conditions are needed to use MAC address for pair. Of course, if the set device name or RSSI lower limit is unreasonable, the user can also select a device manually for MAC pair. As shown in Figure 4.32, after selecting Logitech device, click the “Connect” button manually for pair.

(2) Auto Pair: when the software begins to test, it will send an auto pair order to CRY574. Then, CRY574 will connect to the bluetooth device searched first randomly.

(3) Connect by MAC Address: use MAC address for pair. The MAC address is a 6-bit hexadecimal value. The address input mode can be code sweep input, manual input or NFC mode reading.

- Code Scan Input: input by scanning a bar code or QR code using a scanner. When choosing to save first N-bit
addresses, after the end of code scan, the last 6-N-bit values will display a selected state, as shown in Figure 4.33. Generally, the value of code scan input is set as 0.

- Manual Input: input MAC address manually on the keyboard. After input, click the “Connect” button or press enter key to connect a bluetooth device. When choosing to save the first N-bit address, after input, the last 6-N-bit value will be deleted. Figure 4.34 shows the input end state of “keeping the first 3-bit address”.

- NFC Mode: for some NFC chip bluetooth devices, the device's MAC address can be read through the card reader. It is necessary to install a specialized NFC driver. When the device is connected, what is shown in the device manager is a serial port. After a serial port and baud rate are selected, the MAC address of the bluetooth device can be read.

4. Timeout: the program judges the timeout of Bluetooth. When sending a pair command, it begins to timer. After the connection begins, the Bluetooth window will display “NowConnecting (n)” and begins to count. If the connection doesn’t succeed in the timeout, “ConnectionTimeOut” will be displayed. The window background is red. If the connection succeeds, “BT connected” will be displayed. The window background is green.

5. Headphone Delay: the time from preparing a headphone test to a real headphone test after the bluetooth headphone is successfully connected. Since a stable process is needed after the device is connected, the stabilization time for different headphones is different.

6. Mic Delay: the time from preparing a microphone test to a real microphone test after the bluetooth mic is successfully connected. Since a stable process is needed after the device is connected or the bluetooth mode is switched (from A2DP to HFP), the stabilization time for different microphones is different.

Note: Headphone delay and Mic delay are global variables. For all steps in which the device type is bluetooth headphone or bluetooth mic, this delay time is needed.

7. Reset Dongle By Every Time: Before each test reset Dongle first. Some bluetooth devices may fail to connect after several connections. It is necessary to tick this option to reset Dongle. It generally takes 2 to 3s to reset Dongle.

8. MIC Test Simulate Answer Call: After successfully connected, some bluetooth devices are switched to HFP mode. MIC cannot collect voice, either. It is necessary to send a call simulation order before collecting voice.
4.8.2 Functional Test

Section 4.8.1 introduces “Pair&Connection” in Bluetooth, this section will continue with another module of Bluetooth - “Functional Test”, as shown in Figure 4.36.

1. Auto Test After Connection: when the bluetooth device is connected, a functional test will be carried out automatically. After the functional test, an electroacoustic test will be conducted. If all functions are ticked according to Figure 4.36, the display effect of Bluetooth and test content is shown in Figure 4.30.

2. Read Device Information: read information of the tested bluetooth device. The device information includes bluetooth device name, MAC address, model and volume.

3. RSSI power: read the RSSI power value of tested bluetooth device. The pass Mix/upper limit is set for verdict. The delay time is the waiting time after RSSI power is read, to prepare time for headphone listening.

4. A2DP Music: in A2DP mode, the bluetooth device plays a selected length of music. The file playing path and playing time can be set.

5. HFP/HSP Record: in HFP/HSP mode, the bluetooth mic collects a selected length of music. The recording time and lower limit of loudness can be set.

6. HFP/HSP Playback: in HFP/HSP mode, the sound recorded in the last step is played back. The playback time can be set.

7. Key Test: in HFP mode, the “volume+”, “volume-” and “play/pause” buttons of the device can be detected.

4.9 Jump

This step can control the procedure of test steps.
First of all, determine whether steps selected before Jump step or all steps pass. If pass, then go to the step selected when pass. If fail, then go to the step selected when failed. The test times are used to control the times of Jump executions. Every time this step is executed, 1 will be added. When ticking “Jump out test cycle when the result is pass”, if the step passes, it will stop counting, jump out of the loop and execute the step after this Jump step.

4.10 Custom

This step is a reserved item.

4.11 Curve Limits Setup

Three kinds of open mode: “Setup”→“Curve limits Editor” in the menu bar; Click the right mouse button in the curve window, select “Curve limits Editor”; Shortcut key “F8”;

“Curve Limits Setup” is shown in Figure 4.38. There is frequency response, THD, THD+Noise, Rub&Buzz, Rub&Buzz Norm, impedance, phase and balance curves limits. If the check box before the curve is not ticked, this curve has no curves limits. If curves limits should be set, then tick a corresponding check box. “Frequency response” curve limits has be taken to give an introduction.
Curve Limits Type (L/R)

- L/R Same: when ticked, the left and right curves use the same curve limits setup, including shape and position. When not ticked, the curves limits of the left and right curves are set independently.
- Target Channel: when “L/R Same” is not ticked, select the curve channel of curve limits to be set.

Source Baseline

- Channel (L/R): select a benchmark curve channel, i.e., select whether the actual test curve of the L Channel or the actual test curve of the R Channel shall be taken as a benchmark curve.
- Test: when clicking the “Test” button, set test times and calculate the average of curve as a benchmark curve.
- Import Curve: import a curve from Excel files in the format of external recall curve as a benchmark curve.

Alignment: the alignments include Floating Limits, Absolute Limits and Floating Data.

To facilitate the setup of curves limits, the software introduces the concept of reference value, that is, the actual curves limits are obtained by drawn curves limits+ reference value. The drawing principle of benchmark curve in the curves limits setup interface is to translate the actual curve to 0, according to the reference frequency point, as shown in Figure 4.39. The reference frequency is 1k. The reference value is 90dB. That is, after the curves limits are set, the curves limits center of 1kHz should be in 90dB.

Floating Limits:

The overall curves limits can translate up-down along with the measured curve. This section illustrates the effect of floating frame method by taking “Curve Offset Using Fit Points” as an example:

- Determine the shape and position of the upper and lower curves limits;
- When starting testing, the upper and lower curves limits moves up-down along with the measured curve. The principle of the floating frame method is to make sure the measured curve points to fall within the curves limits as much as possible. If it touches the curves limits, the upper and lower limits will touch the curve together.

Note: The move up-down range cannot exceed the “Floating limits Max Offset”. Otherwise, fix the upper and lower curves limits on the “Floating limits Max Offset”, namely, the nearest principle.

Absolute Limits:

The curves limits are fixed and immobile. The principle and effect of fixed frame method is illustrated by taking “Curve Offset Using Fit Points” as an example:

- Complete the setup of upper and lower curves limits in the curves limits setup interface, with the up-down translation of the measured curve as the curves limits;
- Determine the finally position of curves limits in the test window, according to “frequency response frame reference value” in the scheme setup interface. Figure 4.39 illustrates the determination process of curves limits position. In the figure, the reference value of frequency response frame is 90dB;
During the test, the position of curves limits remains unchanged.

- **Floating Data:**
  - The curve moves based on the reference point, and the rest steps are same as the fixed limit method.
  - Determine the shape and position of the upper and lower curves limits, and the first two steps are same as the fixed limit method;
  - The measured curve moves based on the reference frequency point and reference value. If the “Frequency Response Frame Reference Frequency”=1000Hz, "Response Frame Reference Value"=100dB, and the sensitivity at the actual measured curve at 1kHz =90dB, and thus the interface display will translate the curve upwards 10dB, as shown in Figure 4.40, while the curves limits position is fixed.

**Note:** When using the Floating Data method, the measured curve moves in the interface based on the reference value, but the original data is still in the display window of sensitivity data.
### Table 4.4  Summary Sheet of Alignments

<table>
<thead>
<tr>
<th>Alignments</th>
<th>Measured Curve</th>
<th>Curves limits</th>
</tr>
</thead>
<tbody>
<tr>
<td><strong>Absolute Limits method</strong></td>
<td>Fixed on the testing position</td>
<td>Fixed on the setup position</td>
</tr>
<tr>
<td><strong>Floating limits method</strong></td>
<td>Fixed on the testing position</td>
<td>Move the curves limits, to make sure the measured curve points to fall into the curves limits as much as possible</td>
</tr>
<tr>
<td><strong>Floating Data method</strong></td>
<td>Translate to the target points (frequency response frame reference frequency, frequency response frame reference value), for example, translate the curve 1kHz to 0dB</td>
<td>Fixed on the setup position</td>
</tr>
</tbody>
</table>

(4) Curve limits setup method: Fit Points and Absolute Value.

- **Fit Points**: as shown in Figure 4.41. The “New” icon is used to add frequency and offset. The “Clear” icon is used to clear the set frequency band. The “Copy” button is used to copy offset between the upper and lower curve limits.

  When setting curves limits using Fit Points, it is necessary to sweep frequency once to get a benchmark curve.

  The Fit Points translate data according to the set offset. If the offset is different, for example, 3dB for 20Hz and 5dB for 1000Hz, in this case, the point shift 3dB at 20Hz and shift 5dB at 1000Hz, for points between 20Hz and 1000Hz, the offset is translated according to the slope of the curve.

![Figure 4.41  Fit Points Setup](image1)

![Figure 4.42  Absolute Value Setup](image2)

- **Absolute Value**: as shown in Figure 4.42, the list of frequency points shows the offset values of current curves limits.

  The user double clicks to input the offset of each frequency point manually.

(5) **Manual Drawing and Sorting Curve limits**:  

- **Redraw**: clear limits and draw curve limits with two points. Determine the turning point by the left button, right click the mouse to end the drawing curves limits when the completion of the last point; draw the lower curves limits by repeating the above operation. In the process of drawing, the curves limits will be sorted automatically. The same
curve limits won’t be crossed.

- **Undo**: realize the step back function in the course of drawing curve limits. When the upper and lower curve limits are drawn, this function will become invalid.

### 4.12 Save File

The software consists of two saving formats, among which the first one is to save current sweep data and the second one is to continuously save sweep data into the database files.

#### 4.12.1 Save Current Sweep Data

Open mode: “Data” → “Save data” in the menu bar, and Figure 4.43 pops up.

- **Picture**: save the current screen test data and curve in jpg format. It has the same function as the key “Print Screen” on the keyboard. If you only save a specific curve graph, you can right click on the graph view and choose “Picture file” in “Export” of the right-click menu to save it, or choose “Clipboard” to save it and then use Ctrl+V to paste to Drawing, Word or other applications.

- **Excel File**: save the current sweep frequency response, THD, impedance, phase and other data in Excel format. This data saving format is used for both recall curve and standard curve.

![Figure 4.43 Save Current Sweep Frequency Data](image)

#### 4.12.2 Save Sweep Data Continuously

Click “Data” → “Database Setup” on the menu, and the dialog box as shown in Figure 4.44 pops up. At that moment, you can continuously save the setup of required data item.

1. **File Name and File Path**: set the file name and file path for the sweep frequency data; two ways of file names, one is named by the current date, orderly year month day, and it is not editable; the other is custom;

2. **Save When Pass**: the data will be saved when judged as pass.

3. **Save When S/N is not Empty**: save data only when the S/N is not empty.

4. **Public Parameters**: including the testers, device name, test time and S/N; ticking V stands for saving the information in the saving files of sweep frequency data;

5. **Select Test Parameters**: for the test content to be saved in the database file, tick V in the attribute page of corresponding test steps to save the test data.
Before starting the test, single click the “Data”→“Start Save Database”, and the data will be saved to the specified database file continuously after clicking, and end the saving by reclicking the “Data”→“Save to Database File”, the icon being not selected.

Note: If there are multiple test steps, each test step will establish a separate table during the continuously Save Data, and is saved in the same database file.

4.12.3 Curve List

Two kinds of open mode: select the “Curve List” under “Data” in the menu bar, or right click “Curve List” in the curve window;

As shown in Figure 4.45, Curve List can save Excel data automatically in each test (the same as the format of recall file). To save it, you must open the Curve List and tick “Auto Save”, otherwise it will not be saved automatically.

(1) Save Folder Path: set the file path. Under this path, a new folder named after the step will be created automatically. As shown in the figure, two folders “headphone” and “microphone” will be generated automatically to save Excel data files of the headphone and microphone.

(2) Filename:
• Time: with the test time as the file name. The name format is yyyy_mm_dd_hh_mm_ss, for example 2016_05_17_10_37_52.xls.

• S/N: with S/N as the file name. When the S/N is empty, the file won’t be saved. When the saved file already exists, “Re-enter the File Name” window will pop up, as shown in Figure 4.46. The user can rename, overwrite or quit without saving the file.

(3) Select curve name for batch operation, such as frequency response (L) and frequency response (R) in Figure 4.45. In the file name of subsequent tree list, tick to select frequency response (L) and frequency response (R) in the current file. Users can have multiple choices.

(4) Add File or Folder: add the last saved recall file to the tree list. When selecting to add a folder, the entire folder will be traversed.

(5) Auto Save: after ticking “Auto Save”, data will be saved automatically after each test. The “Auto Save” option in each step is independent of each other.

(6) Tree List: the tree list displays the saved data

• Curve Recall: combined with the name selected in Step 3, i.e. when ticking the check box before a file, all curves with corresponding names in this file are selected. Test curves of the same type will be displayed in the currently active graph window. The recall curve is named after the file name. If the check box is not ticked, the tick before the subdirectory curve name and the corresponding curve displayed in the currently active graph window will be deleted simultaneously. The color can be changed by double clicking color in the right side of subdirectory name.

• Right click the tree list. The menu in Figure 4.47 will pop up.

  ✓ Export Selected: export the selected curve data to a new XLS file. Required curve data can be selected quickly through batch operation in Step 3.

  ✓ Delete: delete a selected file from PC hard disks.

  ✓ Delete All: delete all files in the list from PC hard disks.

  ✓ Clear: delete a file from the list. Files in PC hard disks are reserved.

  ✓ Clear All: clear the list. Files in PC hard disks are reserved.

  ✓ Select All: select all files. Meanwhile, select items in the file with the same curve name in Step 3. Display curves of the same type in the currently active graph window.

Note: if there are too many files in the list, the function of “Select All” needs to spend a lot of time in reading and recalling data.

✓ Deselect All: Deselect all files in the list and delete the recall file in the currently active graph window.
4.13 Report

Three kinds of open mode: “Data”→“Report” in the menu bar; tool bar button→“Export Report”; right click the curve window and select “Export”→“Report”;

Click the “Report” button. The window as shown in Figure 4.48 will pop up. The user selects the specifications of each test step respectively, click “OK”, choose Word path and edit the name. Subsequent users can edit the report file. The graph background of report is always white.

4.14 Option Setup

Open mode: “Tools”→“Option” in the menu bar

4.14.1 Verdict

(1) Window Background: set the pass and fail background color respectively, including sequence verdict, step verdict and data verdict, etc.

(2) Window Text: qualification verdict text, namely, text to be displayed when the verdict passes and fails.

(3) Font and Preview: set the font size, color and format, etc. of the sequence verdict text.

(4) Window Size: set the size of sequence verdict. Set the width and height when “Fixed Size” is selected. When it is not ticked, the window size is calculated automatically according to the set font size.

4.14.2 High Frequency Test

When the tested frequency is greater than 20kHz, it is necessary to tick the “High Frequency Test” option, as shown in the following figure.
(1) After setup, it is necessary to restart the software.

(2) If CRY6138 sound card is used, after the software starts, the sound card parameters will be set automatically.

With “High Frequency Test” selected, in the setup interface of “Buffer setup”, choose “Safe” in “USB Streaming Mode” and choose “2048 Samples” in “ASIO Buffer Size”.

With “High Frequency Test” unselected, in the setup interface of “Buffer setup”, choose “Standard” in “USB Streaming Mode” and choose “512 Samples” in “ASIO Buffer Size”.

4.14.3 USB SoundCard

When testing USB headphone or USB mic, you need to select a USB SoundCard, as shown in Figure 4.51.

When PC is only connected to a USB headphone, this USB SoundCard will be selected by default. The user doesn’t have to set it. If multiple USB headphones are inserted, the user needs to choose USB headphones to be tested.
4.14.4 Refresh

![Refresh Setup](image)

When “Clear data and display interface before start” is ticked, each time you start testing, the test data will be removed. The graph window and data display window will be refreshed. Meanwhile, the sequence verdict displays “Testing now...” text. The background color is the set color. This method is applicable for single frequency sweep.

When “Clear data and display interface before frequency sweep” is not ticked, the data and display interface will not be removed.
Part V Typical Application

All the test cases in this chapter can be found in the “lib->example” folder under the installation path.

5.1 Headphone Test

Objective:

➢ Test the frequency response, impedance curve, balance curve and polarity of an analog headphone;
➢ Set the curve limits of frequency response and limits of 1kHz sensitivity and impedance;

Hardware Connection and Operational Context

- Sequence Setup
- Instrument Calibration
- Parameter Setting
  - Input & Output
  - Frequency Response
  - Impedance
  - Balance
- Curve Limits Setup
  - Absolute Limits
  - Fit Points Method
- Add Observation Item
- Start Testing

![Figure 5.1 Hardware Connection of Headphone Test](image)

Detailed Operation Steps

1. Open or Create a New Sequence

   The user can directly open the test template in the folder “\lib\example” under the installation directory, and modify parameters as appropriate according to the current sequence. The software also supports “Save As”.

   Taking the headphone solution in the test template as an example, we open it according to the following steps: “File”→“Open” in the menu bar. Choose “32Ω headphone test.cry” in the folder of “example”.

![Figure 5.2 Open Sequence](image)
2. Sequence Setup

Click “Setup”→“Sequence Editor” in the menu bar. The dialog box as shown in Figure 5.3 pops up, in which there is only one test step-headphone. When selecting the step name “headphone”, the right side will display basic information of the current step, including device type, cycles and information, etc. Users can create and add test steps, add observation item and change the order of execution, etc. using six functional buttons on Sequence Editor. Input/output, frequency response in the left drop-down menu are default test items. Others can be finished through the “Add” button. Please see Section 3.3 for details.

![Figure 5.3  Sequence Editor](image)

3. Instrument Calibration

Click “Calibration” →“Calibration” or shortcut key “F7” (recalibration is needed when using for the first time or changing relevant setup items).

Calibration steps: Instrument Internal Calibration→ Left Microphone Calibration→ Right Microphone Calibration. See Section 3.4 for details.

4. Parameter Setting

- Input/Output Setup

“Setup”→“Sequence Editor”→“Input/Output” or shortcut key “F5”. The dialog box in Figure 5.4 pops up. Select Input/Output test items.

![Figure 5.4  Input / Output Parameter Setting](image)
Stimulus:
Stimulus Type: RMS, Rapid Stepped Sweep, Precise Stepped Sine Sweep, Multitone, White Noise, Pink Noise;
Octave Mode: 1/3 Oct, 1/6 Oct, 1/12 Oct, 1/24 Oct;
Start and Stop Frequency: select according to the needs of products

Output Setup:
Output Port: L (L Channel), R (R Channel), L/R (L Channel + R Channel);
Output Type: Open-circuit voltage, Excitation voltage;

How to choose a suitable headphone output voltage?
The output power of headphone is generally 1mW. According to Formula 5.1 and nominal impedance of product, the voltage value can be calculated. This value is the excitation voltage of products.

\[ P = \frac{V^2}{R} = \frac{V_1^2}{R_2} \]  

(5.1)

If the user needs to set an open-circuit voltage, you can calculate the open-circuit voltage \( V \) according to Formula 5.2 and the excitation voltage \( V_1 \). The circuit diagram is shown in Figure 5.5.

Input Setup:
Sound Range: users need to select a sound range bigger than the maximum sound pressure of the measured products. For example, assuming the maximum sound pressure of the measured device is 110dB, the sound range shall be <120dB;
Input Port: L (L Channel), R (R Channel), L/R (L Channel + R Channel);
Ref. Pressure: select 20uPa.

Frequency Response Setup
Set the limits of 1kHz sensitivity, “Setup”→“Sequence Editor”→“Frequency Response” in the menu bar. The dialog box in Figure 5.6 pops up. If frequency response correction is needed, please tick the corresponding check box. Users are free to edit the limits. Data can be copied between the left and right Channels mutually. See Section 4.2.2 for details.
Figure 5.6  Frequency Response Setup

- **Impedance Setup**

  The setup of limits of 1kHz impedance: “Setup” → “Sequence Editor” → “Impedance” in the menu bar. The dialog box in Figure 5.7 pops up. If frequency response correction is needed, please tick the corresponding check box. Users are free to edit the limits. Data can be copied between the left and Right Channels mutually. See Section 4.2.7 for details.

Figure 5.7  Impedance Setup

- **Balance Setup**

  The setup of upper limit of balance and upper limit of average balance: “Setup” → “Sequence Editor” → “Balance” in the menu bar. The dialog box in Figure 5.8 pops up. See Section 4.2.5 for details.
Figure 5.8 Balance Setup

- Setting of Polarity and L/R Position

“Setup”→“Sequence Editor”→“Others” in the menu bar. The dialog box in Figure 5.9 pops up. Select the check box of polarity test, L/R position. See Section 4.2.13 for details.

Figure 5.9 Setup of Polarity and L/R Position

5. Curve Limits Setup

- Frequency Response

Firstly, a measured curve will be obtained when running the software, which can be used as the reference drawing curve limits.
Secondly, “Setup”→“Curve Limits Editor” in the menu bar. The dialog box in Figure 5.11 pops up. Left click the column of frequency response. Meanwhile, it is necessary to tick the check box.

![Figure 5.11: Frequency Response Curve Limits Setup](image)

The Curve limits setup is shown in Section 4.11. Here, the simplest fixed frame method is taken as an example:

1. The yellow curve in Figure 5.11 is the measured data of software. If the curve needs to be measured again, please click “Test”, to obtain a benchmark curve.

2. Click “Fit Points” in Figure 5.11, set the curve limits options according to Figure 5.12. The offset is set to be 10 db. The data can be copied between left and right.

![Figure 5.12: Curve Offset Using Fit Points](image)
(3) The curve limits are drawn. Two green curve limits in Figure 5.13 are curves obtained by translating the measured curve up and down by 10dB.

(4) Click “OK” to exit the curve limits setup interface. When running, as long as the measured curve is in the curve limits, it shall be judged as pass. Otherwise, it fails.

Figure 5.13  Upper and Lower Curve limits of Frequency Response and Measured Curve

- **Balance**

  “Setup”→“Curve limits Editor” in the menu bar. The dialog box of “Curves Limits Setup” in Figure 5.14 pops up. Left click the column of frequency response. Meanwhile, it is necessary to tick the check box.

Figure 5.14  Balance Curves Limits Setup

Figure 5.15  Curve Offset Using Absolute Value
Draw a balance curve limits by clicking “Absolute Value”, as shown in Figure 5.15. The offset reference is 0dB. The drawing of curves limits follows the principle of “drawing a line with two points”.

- **Impedance**

  The impedance curve limits can be set according to products. The content can be set by referring to the frequency response curves limits above. It will not be elaborated in this section

6. **Add Observation Item**

Users can add required observation items through “View”→“New Data” in the menu bar, as shown in Figure 5.16; See Section 3.5.3 for details. We only give a brief description here.

Select observation item to be displayed to make the ground color blue. Click the “>>” button. The right column shows the finally added observation item.

Users can add data items to be viewed through the corresponding observation item window, for example, 1kHz frequency response. Users can right click this region to add, as shown in Figure 5.17. Polarity can also be added in the other column by right clicking.

![Figure 5.16 Interface of Adding Observation Item](image)

![Figure 5.17 Adding Sensitivity Observation Item](image)

7. **Add Sequence Verdict**

There is a verdict column at the bottom of each observation item window. This column is only related to data items in its own window. Multiple observation windows and verdict windows can be set up simultaneously. Besides, a sequence verdict can be added, through “View”→“Sequence Verdict” in the menu bar. After selecting, the test interface is shown as
Figure 5.18. The sequence verdict items can be setup through “Tools” → “Option” → “Verdict” in the menu bar.

Figure 5.18 Adding Sequence Verdict

8. **New Graph**

- Click “View” → “New Graph” in the menu bar, to make the first curve window display the left and right impedance curves;
- Click “View” → “New Graph” in the menu bar, to make the second curve window display the balance curve;
- Click “View” → “New Graph” in the menu bar, to make the third curve window display the left and right sensitivity curves;

Add three curve windows successfully. Click “Tile Curve Windows” in the tool bar. The effect is shown in Figure 5.19.

9. **Start Testing**

By now, all exemplary setup contents have been completed. Click “Start” to start testing. The test interface is shown in Figure 5.19.
5.2 Electret Mic Test

Objective:

- Test the frequency response of directional electrets microphone 0° and 180°, calculate the differential value of 1kHz;
- Set the curve limits of frequency response, and set the upper and lower limit of working current for the microphone simultaneously.

Hardware Connection and Operational Context

![Hardware Connection of Microphone Test](image)

Detailed Operation Steps

1. **Open or Create a New Sequence**

   The user can directly open the test template in the folder “\lib\example” under the installation directory, and modify parameters as appropriate according to the current sequence. The software also supports “Save As”. The user clicks “File”→“Open” in the menu bar and chooses “Type H microphone test.cry” in the folder of “microphone test”.

2. **Sequence Setup**

   Right click “Setup”→“Sequence Editor” in the menu bar. The dialog box as shown in Figure 5.21 pops up, in which there are two test steps-“microphone 0° test” and “microphone 180° test”. When selecting the step name “microphone 0° test”, the right side will display basic information of the current step, including device type, cycles and information, etc. The sequence type is electret mic. Users can create and add test steps, Add observation item and change the order of
execution, etc. using six functional buttons on Sequence Editor. I/O and frequency response in the left drop-down menu are default test items. Others can be finished through the “Add” button. Please see Section 3.3 for details.

3. Instrument Calibration

Click “Calibration” → “Calibration” or shortcut key “F7” (recalibration is needed when using for the first time or changing relevant setup items).

Calibration steps: Instrument Internal Calibration → Left Microphone Calibration → Right Microphone Calibration.

Complete Artificial Mouth Calibration Using the Left Microphone. See Section 3.4 for details. In this section, the Artificial Mouth Calibration uses “Type H Calibration”. The connection is shown in Figure 5.22.

4. Parameter Setting

- I/O setup

“Setup” → “Sequence Editor” → “Input / Output” or shortcut key “F5”. The dialog box in Figure 5.23 pops up. Select Input / Output test items.

- Stimulus:

  Stimulus Type: RMS, Rapid Stepped Sweep, Precise Stepped Sine Sweep, Multitone, White Noise and Pink Noise.
  Octave Mode: 1/3 Oct, 1/6 Oct, 1/12 Oct, 1/24 Oct;
  Start and Stop Frequency: select according to the needs of products
  Min Cycle and Min Duration: the sound cycles of various frequency points are demarcated by transition. If lower than the transition, follow Min Cycle. If higher than the transition, follow Min Duration (when Precise Stepped Sine
Sweep is selected, this edit box will be activated).

- **Output Setup:**
  - Output Port: Mouth 1 and Mouth 2;
  - Level: input according to actual needs (based on the Artificial Mouth calibration data is calibrated by 1Pa. When 0.5Pa is set, the Artificial Mouth outputs 88dB);

![Parameter Setting Interface](image)

**Figure 5.23 Parameter Setting Interface**

- **Input Setup:**
  - Input Port: L (L Channel), R (R Channel), L/R (L Channel + R Channel);
  - Elec. Range: The voltage range shall be greater than the maximum voltage in device test. For example, if the maximum sensitivity of the tested device is -20dB, it has to be chosen < -10dB for the electrical range.

**Note:** It is observed that there is a difference between I/O items and headphone test here. The user doesn’t have to care about this, for the software can adjust I/O content automatically, according to the test device selected by the user.

- **Mic Current Setup**
  - Add “Mic Current” test item in Sequence Editor. A current attribute page will be added in the corresponding sequence, as shown in Figure 5.24.
  - When “Mic Current” test is ticked, the Mic current is to be tested. Otherwise, it is not tested.

- **Test Setup**
  - Voltage DCV: microphone working voltage. The voltage range is 0~6V.
  - Resistance DCR: Mic current-limiting resistance can be selected in 8 resistance options of the drop-down menu;

- **Verdict Setup:** set the limits of Mic current and Mic voltage;
Note: Before pressing “Apply”, it is necessary to disconnect the tested microphone. Just set once. To change the set voltage or resistance value, it is necessary to reset.

5. Curve Limits Setup

This section adopts absolute value and floating limits method to draw curve limits of “microphone 0° test” for example.

Right click the curve interface→”Curve limits Editor” →”Microphone 0° Test”. Figure 5.25 pops up. The alignment is Floating Limits. The reference frequency, reference value and max offset are set as required. Using absolute value method, specific frequency point and allowable offset are set.

Note: The 0 point coordinate in this interface is the reference value (-30). The max offset of floating limits method is 10dB, suggesting that in the actual test interface, the curve limits of 1kHz frequency point will float between -20 and -40 with the measured curve. If the measured curve exceeds this range, the curve limits cannot move with the curve, but stay in the max offset. See Curve limits setup in Section 4.11 for details.

6. Differential Value Setup

In this example, the 0° and 180° frequency response differential value should be calculated. That is to say, it is needed to establish two new test steps, which have the same setup items. 0° and 180° frequency response are tested respectively. When testing directional microphone, it is needed to add message or Extrigger items between steps, to make users have time to complete the microphone sway action. After that, subsequent tests of sequence are completed through the
message box or footswitch. Here, taking “adding a message box” for example, the steps are shown in Figure 5.26.

Add Step
Choose Message
Move to the suitable position

Figure 5.26  Test Steps of Directional Microphone

Add Differential Value: click “View”→“Differential Value” in the menu bar. Complete the addition of a Differential Value as shown in Figure 5.27. The message prompt is shown in the dialog box of Figure 5.28.

Figure 5.27  Differential Value setup

Figure 5.28  Message Waiting in the Process of Test

7. Add Observation Item

Users can Add observation items for two steps through “View”→“New Data” in the menu bar. Among them, the Mic voltage and Mic current are in “Others”.
8. New Graph

✓ Click “View” → “New Graph” in the menu bar, to make the first curve window display the left frequency response curve for “Microphone 0° Test” step.

✓ Click “View” → “New Graph” in the menu bar, to make the second curve window display the left frequency response curve for “Microphone 180° Test” step.

9. Start Testing

By now, all exemplary setup contents have been completed. Click “Start” to start testing. The test interface is shown in Figure 5.30.

Figure 5.30  The Effect of Directional Microphone Solution Test
5.3 Headphone Microphone Assembly Test

Objective:

- Test the frequency response of the headphone and microphone, and set the curve limits of frequency response;
- Test the Mic current and set the upper and lower limits of it;

Hardware Connection and Operational Context

Detailed Operation Steps

1. **Open or Create a New Sequence**

   The user can directly open the test template in the folder “\lib\example” under the installation directory, and modify parameters as appropriate according to the current sequence. The software also supports “Save As”.

   The user clicks “File” – “Open” in the menu bar, chooses “headphone + microphone test.cry” in the folder of “example”.

2. **Sequence Setup**

   Click “Setup” – “Sequence Editor” in the menu bar, to complete the management of sequence steps.

   1) Add two steps. The test name can be input according to actual needs. The test types are headphone and electret
mic respectively;

2) Add items. Add average frequency response, balance, impedance and other to headphone test and add Mic current for microphone test, as shown in Figure 5.32.

3. Instrument Calibration

Click “Calibration” → “Calibration” or shortcut key “F7” (recalibration is needed when using for the first time or changing relevant setup items).

Calibration steps: Instrument Internal Calibration → Left Microphone Calibration → Right Microphone Calibration → Complete Artificial Mouth Calibration Using the Left Microphone.

See Section 3.4 for details.

4. Parameter Setting

Click “Setup” → “Sequence Editor” in the menu bar. The left side is test steps and test items list. The right side is specific setup information of selected item. Figure 5.33 shows parameters related to Input/Output test items in headphone test step. Users can set it according to needs.

For parameter setting in headphone and microphone test steps, see Parameter Setting in Sections 5.1 and 5.2 for details.

5. Curve Limits Edit

To draw curves limits, please refer to Curves limits in Sections 5.1 and 5.2. This section draws upper and lower curves limits using floating data and Fit Points method. If users need to reduce the upper and lower limits of 1kHz, they can click “Absolute Value”, figure 5.34 will pops up. The relative sound pressure value of each frequency point can be modified.

Taking modifying the relative sound pressure of 1kHz as ±1.0 for example, the final upper and lower curve limits are shown in Figure 5.35.
6. Add Observation Item

Users can add headphone sensitivity (L), sensitivity (R), balance and impedance windows on the left and add microphone sensitivity (L) and others (including Mic current and Mic voltage) on the right, through “View”→“New Data” in the menu bar, as shown in Figure 5.36.
7. New Graph

✓ Click “View” → “New Graph” in the menu bar, to make the first curve window display the left and right frequency response curves for the headphone test step.

✓ Click “View” → “New Graph” in the menu bar, to make the second curve window display the left and right impedance curves for the headphone test step.

✓ Click “View” → “New Graph” in the menu bar, to make the third curve window display the balance curve for the headphone test step.

✓ Click “View” → “New Graph” in the menu bar, to make the last curve window display the frequency response curve for the mic test step.

8. Start Testing

By now, all exemplary setup contents have been completed. Click “Start” to start testing. The test interface is shown in Figure 5.36.

Figure 5.36 The Effect of Headphone & Microphone Assembly Test
5.4 Speaker Test

Objective:

- Test the frequency response, impedance curve of speaker;
- Set the verdict frame of frequency response and observe the resonant frequency of F0;

Hardware Connection and Operational Context

![Figure 5.37 Hardware Connection of Speaker Test](image)

Detailed Operation Steps

1. **Open or Create a New Sequence**

   The user can directly open the test template in the folder “\lib\example” under the installation directory, and modify parameters as appropriate according to the current sequence. The software also supports “Save As”.

   The user clicks “File” → “Open” in the menu bar and chooses “Speaker Test.cry” in the folder of “Speaker Test”.

2. **Sequence Setup**

   Click “Setup” → “Sequence Editor” in the menu bar, to complete the management of sequence steps.

   1) Add two steps, to test speaker frequency response curve and impedance curve respectively. The test type selects speaker. For reasons to separate tests, see Figure 5.38 Test Steps.
Parameter Setting;

2) Add items, such as impedance, F0 and Q value for speaker test, as shown in Figure 5.38.

3. Instrument Calibration

Click “Calibration” ➔ “Calibration” or shortcut key “F7” (recalibration is needed when using for the first time or changing relevant setup items).

Calibration steps: Instrument Internal Calibration ➔ Left Microphone Calibration. See section 3.4 for details.

4. Parameter Setting

● Speaker Frequency Response Test

Click “Setup” ➔ “Sequence Editor” in the menu bar. The left side is test steps and test item list. The right side is specific setup information of selected items. Figure 5.39 shows parameters related to Input/Output test items in speaker frequency response test. Users can set it according to needs.

Figure 5.39 Parameter Setting

✓ Stimulus:

Stimulus Type: RMS, Rapid Stepped Sweep, Precise Stepped Sine Sweep, Multitone, White Noise and Pink Noise.

Octave Mode: 1/3 Oct, 1/6 Oct, 1/12 Oct, 1/24 Oct;

Start and Stop Frequency: select according to the needs of products

✓ Output Setup:

Output Port: L (L Channel), R (R Channel), L/R (L Channel+ R Channel);

Output Type: open-circuit voltage, excitation voltage;

✝ How to choose a suitable speaker output voltage?

The excitation voltage V1 of speaker is calculated by Formula 5.3, among which R and R2 are nominal impedances of speaker, while P is not directly rated power. Based on technical standards for electroacoustic devices, execute according to
Table 5.1.

\[ P = \frac{U^2}{R} = \frac{V^2}{R^2} \]  

(5.3)

Table 5.1: Speaker Equivalent Method Involved in Output Voltage Calculation

<table>
<thead>
<tr>
<th>Rated Power Pe of Speaker</th>
<th>Equivalent Power P Substituted Into the Formula</th>
</tr>
</thead>
<tbody>
<tr>
<td>Pe ≥ 10W</td>
<td>P = 1W</td>
</tr>
<tr>
<td>1W ≤ Pe ≤ 10W</td>
<td>P = 0.1Pe</td>
</tr>
<tr>
<td>Pe ≤ 1W</td>
<td>P = 0.1W</td>
</tr>
</tbody>
</table>

What Formula 5.3 calculates is the excitation voltage. If users need to set open-circuit voltage, they can calculate the open-circuit voltage \( V \) according to Formula 5.4 and excitation voltage \( V_1 \). The schematic of circuit is shown in Figure 5.40.

In this example, 8Ω/0.5W speaker is used, therefore, the excitation voltage is set as 894mV. Considering the open-circuit output voltage and output resistor power, the output impedance can only be 0Ω in this sequence. Therefore, only frequency response can be tested. See the next page for the impedance test solution.

Figure 5.40  Description of Output Voltage Circuit

\[ V_1 = V \times \frac{R_2}{R_1 + R_2} \]  

(5.4)

Notes:

1. If the output impedance in Speaker Test is 0Ω, then this step can only test frequency response. It is necessary to add a test step to test impedance. The output voltage is modified as open-circuit voltage. According to the size of selected output impedance, the power on both sides of output impedance is less than 0.5W. This solution just adopts this method and sets up two test steps;

2. If other resistance values are chosen for the output impedance, please make sure that the power on both sides of output impedance less than 0.5W. The size of output voltage can be reduced as appropriate, or the nominal impedance can be increased. Otherwise, some circuits of output impedance in the circuit board will be burnt out.

Input Setup:

Sound Range: users need to select a sound range bigger than the maximum sound pressure of the measured device, for example, assuming the maximum sound pressure of the measured device is 110dB, the sound range shall be <120dB;

Input Port: L (L Channel), R (R Channel), L/R (L Channel+ R Channel);
Reference Pressure 0dB: select 20uPa.

✓ Frequency Response:

Click frequency response test items and complete the setup of upper and lower limits of L Channel 1kHz frequency response.

- Speaker Impedance Test

![Figure 5.41 Input / Output Setup](image)

Click Input / Output for the speaker impedance test step and complete parameter setting according to Figure 5.41.

Click impedance and complete the setup of upper and lower limits of L Channel 1kHz impedance;

Click F0 and Q value and complete corresponding setup;

See Section 4.2 for meanings and modification methods of detailed parameters.

4. Curve Limits Setup

![Figure 5.42 Sensitivity Curve Limits Setup](image)
A measured curve will be obtained when running the software for the first time, which can be used as the reference drawing curve limits.

Secondly, “Setup” → “Curve limits Editor” in the menu bar. “Curve Limits Setup” in 5.42 pops up. Left click to activate the column of frequency response.

The curve limits setup is shown in Section 4.11. Here, the simplest absolute limits method is taken as an example:

(1) The yellow curve in figure 5.42 is the measured data of software by default. If the curve needs to be measured again, please click “Test”, to obtain a benchmark curve.

(2) Set the curve limits options according to Figure 5.42.

(3) Click “Fit Points”, window as shown in Figure 5.43 pops up. The offset is set to be 3db. The data can be copied between left and right.

(4) The curves limits are drawn. Two green curves limits in Figure 5.42 are curves obtained by translating the measured curve up and down by 3dB.

(5) Click “OK” to exit the curves limits setup interface. When running, as long as the measured curve is in the curves limits, it shall be judged as pass. Otherwise, it fails.

![Figure 5.43  Curve Offset Using Fit Points](image)

6. Add Observation Item

Users can add required observation items through “View” → “New Data” in the menu bar. Add 1kHz frequency response and curve limits verdict for frequency response test. Add 1kHz impedance and T&S parameter for impedance test, as shown in Figure 5.44. See Section 3.5.3 for details.

![Figure 5.44  Add Observation Item](image)
7. New Graph

✓ Click “View” → “New Graph” in the menu bar, to make the first curve window display the left frequency response curve for “speaker frequency response test” step.

✓ Click “View” → “New Graph” in the menu bar, to make the second curve window display the left impedance curve for “speaker impedance test” step.

✓ After adding 2 curve windows successfully, click “Tile Curve Windows” in the tool bar. The effect is shown in Figure 5.45.

8. Start Testing

By now, all exemplary setup contents have been completed. Click “Start” to start testing. The test interface is shown in Figure 5.45.

![Figure 5.45 The Effect of Speaker Solution Test](image-url)
5.5 USB Headphone Microphone Assembly Test

Objective:

- Test the frequency response of the USB headphone and microphone;
- Set the curve limits of frequency response;

Hardware Connection and Operational Context

![Hardware Connection of USB Headphone Microphone Assembly Test](image)

Figure 5.46  Hardware Connection of USB Headphone Microphone Assembly Test

Detailed Operation Steps

1. **Open or Create a New Sequence**

   The user can directly open the test template in the folder “\lib\example” under the installation directory, and modify parameters as appropriate according to the current sequence. The software also supports “Save As”.

   The user clicks “File”→“Open” in the menu bar and chooses “USB Headphone+Microphone.cry” in the folder of “USB Headphone+Microphone test”.

2. **Sequence Setup**

   Click “Setup”→“Sequence Editor” in the menu bar, to complete the management of sequence steps.

   1) Add two steps. The test name can be input according to actual needs. The test types are USB headphone and USB mic respectively;

   2) Add items, to add average frequency response and others (polarity, headphone position) for USB headphone and add average frequency response test items for USB mic test;
3. Instrument Calibration

Click “Calibration” → “Calibration” or shortcut key “F7” (recalibration is needed when using for the first time or changing relevant setup items).

Calibration steps: Instrument Internal Calibration → Left Microphone Calibration → Right Microphone Calibration → Complete Artificial Mouth Calibration Using the Left Microphone. See Section 3.4 for details.

4. Parameter Setting

Click “Setup” → “Sequence Editor” in the menu bar. The left side is test steps and test item list. The right side is specific setup information of selected items. Figure 5.47 shows parameters related to Input/Output test items in USB headphone test steps. Users can set it according to needs.

- Output Type: as the test type is USB, here the output type is digital signal output by default;
- Output Level: the digital signal level can be set according to actual needs;
- For other setup, see Parameter Setting in Sections 5.1 and 5.2, basically the same as common headphone and microphone.

![Parameter Setting](Figure 5.47 Parameter Setting)

5. Curve Limits Setup

To draw curve limits, please refer to sections 5.1 and 5.2. This section adopts floating limits and Fit Points method, as shown in Figure 5.48. In this figure, using Fit Points, the upper and lower curve limits of headphone frequency response, with an offset of 5dB.
Figure 5.48  The Frequency Response Curve Limits Setup for USB Headphone Step

Figure 5.49 draws the upper and lower curve limits of USB mic frequency response with an offset of 3dB. If users need to reduce the upper and lower limits of 1kHz, they can click “Absolute Value”. A dialog box as shown in Figure 5.50 pops up. The relative sound pressure value of each frequency point can be modified. Taking modifying the relative sound pressure of 1kHz as ±1.0 for example, the final upper and lower curves limits are shown in Figure 5.51.

Figure 5.49  USB Mic Step Frequency Response Curve Limits Setup 1
6. Add Observation Item

Users can add USB headphone sensitivity (L) and sensitivity (R) windows on the right, add USB mic sensitivity (L) on the right through “View”→“New Data” in the menu bar. Users can drag the mouse and make two windows displayed in a column. The effect is shown on the right side of Figure 5.52.

7. New Graph

✓ Click “View”→“New Graph” in the menu bar, to make the first curve window display the left and right frequency response curves for the USB headphone test step.
✓ Click “View”→“New Graph” in the menu bar, to make the second curve window display the left frequency response for USB mic test step;
✓ Click “View”→“Tile Curve Windows”, to display two curve interfaces simultaneously and tile them in the curve display window, as shown in Figure 5.52.
8. Start Testing

By now, all exemplary setup contents have been completed. Click “Start” to start testing. The test interface is shown in Figure 5.52.

Figure 5.52  The Effect of USB Headphone Microphone Assembly Test
5.6 Bluetooth Headphone Microphone Assembly Test

Objective:

➢ Test the frequency response of the bluetooth headphone and microphone;
➢ Set the curve limits of frequency response;
➢ Set the upper and lower limits of 1kHz sensitivity;

Hardware Connection and Operational Context

![Hardware Connection Diagram]

- Sequence Setup
- Instrument Calibration
- Bluetooth Audio Setup
- Parameter setting
  - Input / Output
  - Frequency Response
- Curve Limits Setup
  - Absolute Limits
  - Fit Points Method
- Add Observation Item
- Start testing

Figure 5.53  Hardware Connection of Bluetooth Headphone Microphone Assembly Test

Detailed Operation Steps

1. **Open or Create a New Sequence**

   The user can directly open the test template in the folder “\lib\example” under the installation directory, and modify parameters as appropriate according to the current sequence. The software also supports “Save As”. The user clicks “File”→“Open” in the menu bar and chooses “bluetooth Headphone+Microphone.cry” in the folder of “bluetooth test”.

2. **Sequence Setup**

   Click “Setup”→“Sequence Editor” in the menu bar. The given test template has added two test steps- “bluetooth headphone” and “bluetooth mic”. But here we still need to add the “Bluetooth” step, to realize connection and test, as
shown in Figure 5.54. The test step, Bluetooth, is moved to the top through “Move up Button”, i.e., start running in the earliest time.

3. Instrument Calibration

Click “Calibration” → “Calibration” or shortcut key “F7” (recalibration is needed when using for the first time or changing relevant setup items).

Calibration steps: Instrument Internal Calibration → Left Microphone Calibration → Right Microphone Calibration. See Section 3.4 for details.

4. Sequence Setup

Click “Setup” → “Sequence Editor” in the menu bar. The left side is test steps and test item list. The right side is specific setup information of selected items. Figure 5.55 shows parameters related to Bluetooth test step. Below a brief description is given on Bluetooth. See Section 4.8 for details.

1) **Set Pair** (There are three kinds of pair modes. Choose one of them for corresponding setup)

![Figure 5.56 Bluetooth Parameter Setting in Different Pair Modes](image)
Search Pair Mode: search bluetooth devices nearby bluetooth that could satisfy the requirement of name or RSSI and connect to the first searched device.

Timeout: when the device is not found beyond this time limit, it will stop searching;

Headphone Delay: set up a connection and wait when entering the headphone test step (the waiting time is based on the set value);

Mic Delay: set up a connection and wait when entering the microphone test step (the waiting time is based on the set value);

Reset Dongle By Every Time: when this item is selected, it will reset when connection;

Mic Test Simulate Answer Call: when this item is chosen, it will send specific commands to simulate incoming call answering when entering the microphone test step;

Pair by Device Name: after this item is selected, only bluetooth devices with the same name as in the textbox are searched.

Pair by RSSI Val: after this item is selected, only bluetooth devices whose RSSI value is greater than the lower limit are searched;

✓ Auto Pair Mode: search all nearby bluetooth devices and connect to the first searched device

✓ MAC Address Mode: search bluetooth devices nearby with the same MAC address input

MAC Connect: including code scan input and manual input. The resulting MAC address can be retained according to the retained number of digits. For example, MAC address is 00 0D 44 9F 84 C6. 3 digits are retained. After the test interface is successfully connected, the MAC address column shows 00 0D 44;

2) Set Functional Tests

![Bluetooth Functional Test Setup](image-url)

Figure 5.57 Bluetooth Functional Test Setup
**Auto Test After Connect:** If this item is selected, after bluetooth headphone is successfully connected, it will finish the selected test content in Figure 5.57. The actual Bluetooth and test content interface are shown in Figure 5.58.

**Content:**

- **Read device information:** read bluetooth device name, MAC address, mode and volume information;
- **RSSI Power:** read RSSI power of the measured bluetooth device and make a qualification verdict according to the set upper and lower limits
- **A2DP Music:** search play files according to displayed address. The time is subject to the set value;
- **HFP/HSP Record:** record according to the set time. When there is a sound with a set lower limit when recording, it shall be judged as pass.
- **HFP/HSP Playback:** play back record files in the last step;
- **Key Test:** simulate by pressing volume+, volume- and play/pause buttons in the measured device. Three buttons can be selected according to actual devices. Every time they are pressed, digits after corresponding buttons in Figure 7 will increase by 1. If all selected buttons can respond, it shall be judged as pass;

All setup related to Bluetooth are completed above. Setup related to bluetooth headphone and bluetooth mic test steps shall not be specified here. Basically similar to the test simulation equipment, only the test type and signal type need to be modified. See Parameter Setting in Sections 5.1 and 5.2 for details.

5. **Add Observation Item**

Users can add bluetooth headphone sensitivity (L), sensitivity (R), balance items and bluetooth microphone sensitivity on the right through "View”→“New Data” in the menu bar.

6. **New Graph**

- Click “View” →“New Graph” in the menu bar, to make the first window display the left and right frequency response curves for the bluetooth headphone test step.
- Click “View” →“New Graph” in the menu bar, to make the second window display the left frequency response for bluetooth mic test step;
✓ Click “View” → “Tile Curve Windows”, display two curve interfaces simultaneously and tile them in the curve display window, as shown in Figure 5.59.

7. Start Testing

By now, all exemplary setup contents have been completed. Click “Start” to start testing. The test interface is shown in Figure 5.59.

![Figure 5.59 The Effect of Bluetooth Stereo Headphone Solution Test](image-url)
## Part VI Troubleshooting Methods

### 6.1 PC Part

<table>
<thead>
<tr>
<th>S.N.</th>
<th>Phenomenon</th>
<th>Troubleshooting Reason</th>
<th>Solutions</th>
</tr>
</thead>
<tbody>
<tr>
<td>1.1</td>
<td>Main power indicator light does not shine</td>
<td>A. Bad contact</td>
<td>A. Check the power line or switch</td>
</tr>
<tr>
<td></td>
<td></td>
<td>B. The power switch is not started</td>
<td>B. The back panel power fan does not work, please replace the power supply timely</td>
</tr>
<tr>
<td></td>
<td></td>
<td>C. Bad switching power supply</td>
<td></td>
</tr>
<tr>
<td>1.2</td>
<td>The host power indicator light on, but the display is abnormal</td>
<td>A. Poor display power supply</td>
<td>A. Check the connection line for each display</td>
</tr>
<tr>
<td></td>
<td></td>
<td>B. Bad contact between display card and a host</td>
<td>B. Check whether the display card has a good contact with the motherboard</td>
</tr>
<tr>
<td></td>
<td></td>
<td>C. Display card is damaged</td>
<td>C. Change the display card or monitor</td>
</tr>
<tr>
<td>1.3</td>
<td>The computer can’t self testing</td>
<td>A. Bad memory</td>
<td>A. Replace the memory item</td>
</tr>
<tr>
<td></td>
<td></td>
<td>B. BIOS settings are incorrect</td>
<td>B. Reset</td>
</tr>
<tr>
<td></td>
<td></td>
<td>C. Other reasons</td>
<td>C. Check whether the expansion card has a good contact with the motherboard</td>
</tr>
</tbody>
</table>

### 6.2 Signal Plate Part

<table>
<thead>
<tr>
<th>S.N.</th>
<th>Phenomenon</th>
<th>Troubleshooting Reason</th>
<th>Solutions</th>
</tr>
</thead>
<tbody>
<tr>
<td>2.1</td>
<td>No signal in the signal output port</td>
<td>A. No ±15V analog voltage</td>
<td>A. Check the fuse and power supply board</td>
</tr>
<tr>
<td></td>
<td></td>
<td>B. The power amplifier circuit is damaged</td>
<td>B. Check the power amplifier circuit</td>
</tr>
<tr>
<td></td>
<td></td>
<td>C. The software settings is incorrect</td>
<td>C. Check the signal generating circuit</td>
</tr>
<tr>
<td></td>
<td></td>
<td>D. The output line turnoff</td>
<td>D. Retest after the point calibration</td>
</tr>
<tr>
<td>2.2</td>
<td>No output signal for artificial mouth, but the signal output port has signals</td>
<td>A. No calibration for artificial mouth</td>
<td>A. Acoustic calibration after electrical calibration</td>
</tr>
<tr>
<td></td>
<td></td>
<td>B. The software is not in the “artificial mouth output” state</td>
<td>B. Set as “artificial mouth output”</td>
</tr>
<tr>
<td></td>
<td></td>
<td>C. The relay control circuit is damaged</td>
<td>C. Check relay control circuit</td>
</tr>
<tr>
<td>2.3</td>
<td>Electrical signal output voltage does not match with setting value</td>
<td>A. No electrical calibration</td>
<td>A. Re electrical calibration</td>
</tr>
<tr>
<td></td>
<td></td>
<td>B. Signal generating circuit did not get through</td>
<td>B. Check the signal source board and measure relevant circuit</td>
</tr>
<tr>
<td></td>
<td></td>
<td>C. Sound card is damaged</td>
<td></td>
</tr>
</tbody>
</table>
### 6.3 Measuring Plate Part

<table>
<thead>
<tr>
<th>S.N.</th>
<th>Phenomenon</th>
<th>Troubleshooting Reason</th>
<th>Solutions</th>
</tr>
</thead>
</table>
| 3.1  | When “Microphone input”, the interface displays a straight line | A. Measuring microphone input turns off or damaged  
B. The preamplifier input turns off or damaged  
C. The input signal is too large | A. Check and replace the measurement microphone  
B. Check and replace the preamplifier  
C. Reduce the input signal |
| 3.2  | When “electrical signal input”, the interface displays a straight line | A. Input signal of electrical signal is too large, open circuit or short circuit  
B. The measurement range setting is incorrect  
C. The switching circuit of input signal of measurement plate is damaged | A. Reduce the input signal  
B. Set the appropriate range  
C. Check the input circuit and connection  
D. Check the input signal switching circuit |
| 3.3  | Calibration curve of artificial mouth, 0.1k~10kHz is not straight | A. The artificial mouth calibration is incorrect  
B. Measurement microphones and artificial mouth position is incorrect | A. Repeat the acoustic calibration  
B. Re calibrate after correcting the measurement microphones and artificial mouth position |
| 3.4  | Electrical calibration is FAILED | A. No signal output in signal board  
B. Bad sound card, signal board and measuring plate connection | A. Check the signal circuit board  
B. Check whether the sound card is normal  
C. Check whether the connection is normal |
| 3.5  | Impedance test value is incorrect | A. The nominal impedance setting is incorrect  
B. The circuit connection is incorrect | A. Reset the impedance  
B. Check the circuit connection |
Part VII Notes

- The software setting in Chapter IV is the most basic function. If users need to expand the function, such as testing the indicators of the contact receiver and the inherent noise level under A-weighted, please contact us to customize the software.
- Avoid to burn the instrument, users should be take care about the signal wire should not be shorted to the signal ground wire and the power supply must not be shorted to any ground wire while in use.
- The instrument should be operated by professional and technical personnel, to guarantee the long-term excellent performance. If you have any questions, please contact with us.
- This instrument is guaranteed for one year.
Appendix: Professional words explanation and model description

**Artificial Ear:** It is a device used to provide acoustic coupling between headset and microphone. It will load the acoustic impedance similar to human ear to the sound source when coupling the sound source. The CRY318 Artificial Ear developed by our company meets the IEC 30618.1 standard, suitable for measuring non-ear headset. And the CRY711 Artificial Ear meets the IEC60318.4 standard (the previous IEC711), suitable for measuring the in-ear headset.

**Artificial Mouth:** It is a device used to simulate the sound source near and around the human mouth, suitable for testing the acoustic parameter index of the telephone transmitter and the microphone used in the voice communication. The frequency response curve and other curves of the CRY600 series artificial mouth researched and designed by our company conforms to international standard of IEEE 269,661 and the acoustic signal requirements of “mouth reference point” suggested by ITU-T P51. And thus it is the acoustic measurement standard source.

**Preamplifier:** It is a amplifier to translate the micro current high impedance after the transducer of the measurement microphone into of low impedance voltage signal. The CRY500 series preamplifier designed and produce by our company can coordinate with the 1/2 inch pre polarization measurement microphone, like B&K, G.R.S.S. and so on, and also compatible with the piezoelectric ceramics vibration sensor.

**Measurement Microphones:** It is a electro acoustic converter used to measure the sound pressure, its sensitivity is known under specified conditions, with the characteristics of wide and flat frequency response, good stability and large dynamic range usually. The CRY331 microphone designed by our company is a pre polarization microphone of free field, used for measuring the distortion less and real sound pressure before putting the microphone into the sound field; and CRY332/372 microphone is a pre polarization microphone of pressure field, suitable for measuring the actual sound pressure on the surface of microphone vibrating diaphragm (including the change of sound field caused by the microphone itself).

**Octave:** Upper limit frequency within the A band range is two times of the lower frequency, octave divided by this way is called 1 octave or octave, and English abbreviated Oct.

**1/3 Octave:** Two frequency points are inserter between the upper a lower limit frequencies of the 1 octave, to divide a frequency interval into 3 frequency intervals, and the ratio among the four frequency intervals
are the same, namely G3=2, and English abbreviated 1/3 Oct. In a similar way, we can understand 1/6 Oct, 1/12 Oct and 1/24 Oct.

**Calibration:** The sound level calibrator for acoustic calibration is needed before using the electroacoustic testing device, and sound level calibrator generates 1kHz, 94dB SPL.

**Fundamental Wave:** In the sound signal, the component sine wave equals the longest period of this oscillation is called the fundamental wave.

**Harmonic Wave:** In the sound signal, the component sine wave whose frequency is equal to an integer multiple of that of the fundamental wave is called harmonic wave, for example, the wave whose frequency equals two times of the fundamental frequency is called “second harmonics”.

**Receiver:** It is a device to convert the electrical signals into sound signal, such as headset, speaker, loudspeaker and so on; The main technical parameters include the sensitivity, frequency response, impedance and so on.

**Transmitter:** It is a device to convert the sound signal into electrical signal, such as the microphone, sound head and so on. The main technical parameters cover the sensitivity, frequency response, output impedance, SNR, current and so on;

**Electrical Signal Input State:** It is a process that the signal input the instrument directly from the electrical signal input port.

**Acoustic Signal Input State:** It is a process that the acoustic signal input the instrument from the artificial ear input port through being converted by the measurement microphone and preamplifier.
© CRY Sound Co., Ltd.

Add: No. 31-1, Xianxing Road, Xianlin Industrial Park,
Yuhang District, Hangzhou, Zhejiang
Tel: 86-571-88225198, 88225128
Fax: 86-571-88225178
E-mail: cry@crysound.com
www.crysound.com

© Southern office of CRY Sound Co., Ltd.

Add: Room 801, Building B, Baian Center, First International Center Phase Two,
Nancheng District, Dongguan, Guangdong Province
Tel: 0769—21688120
Fax: 0769—21688150
Mob: 13823514540
P.C.: 523070